Can't install nightly worksheet for Scala IDE V2.1.0 for Scala 2.1.0 nightly #106

Closed
asampal opened this Issue Oct 27, 2012 · 1 comment

Comments

Projects
None yet
2 participants
@asampal

asampal commented Oct 27, 2012

The nightly worksheet for Scala-IDE 2.1.0 with Scala 2.1.0 is currently broken as it seems to depend on a Scala-IDE version that is just slightly off. I had it installed and working, but, as of about Octover 22nd, when I tried to update plugins my I got errors about an unresolvable dependency. I tried uninstalling the worksheet and re-installing, but had no luck. The current message I'm getting is this:

Cannot complete the install because one or more required items could not be found.
Software being installed: Scala Worksheet 0.2.0.nightly-2_10-201210270333-be42feb (org.scalaide.worksheet.feature.feature.group 0.2.0.nightly-2_10-201210270333-be42feb)
Missing requirement: Scala Worksheet 0.2.0.nightly-2_10-201210270333-be42feb (org.scalaide.worksheet.feature.feature.group 0.2.0.nightly-2_10-201210270333-be42feb) requires 'org.scala-ide.sdt.feature.feature.group [2.1.0.nightly-2_10-201210270323-ef3e820]' but it could not be found

This was after I had just upgraded to the latest Scala-IDE with version:
2.1.0.nightly-2_10-201210270322-1e79bba

Note the version of the IDE the worksheet is looking for - it's the same day as the build that is available on the update site, but just slightly later.

@dotta

This comment has been minimized.

Show comment Hide comment
@dotta

dotta Oct 27, 2012

Member

This is not an issue, it's how it is supposed to work. To avoid any sort of binary incompatibility, you need to update the Worksheet nightly always together with the Scala IDE nightly, as the former has a strict dependency with the latter. You can do so by simply clicking on Help > Check For Updates and update the two plugins together.

Member

dotta commented Oct 27, 2012

This is not an issue, it's how it is supposed to work. To avoid any sort of binary incompatibility, you need to update the Worksheet nightly always together with the Scala IDE nightly, as the former has a strict dependency with the latter. You can do so by simply clicking on Help > Check For Updates and update the two plugins together.

@dotta dotta closed this Oct 27, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment