Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

In Scalac.scala jvm-1.8 is not an allowed target for the ant tool #8966

Closed
scabug opened this issue Nov 7, 2014 · 3 comments

Comments

@scabug
Copy link

commented Nov 7, 2014

In src\compiler\scala\tools\ant\Scalac.scala jvm-1.8 is not in the list:

/** Defines valid values for the target property. */
object Target extends PermissibleValue {
val values = List("jvm-1.5", "jvm-1.6", "jvm-1.7")
}

@scabug

This comment has been minimized.

Copy link
Author

commented Nov 7, 2014

Imported From: https://issues.scala-lang.org/browse/SI-8966?orig=1
Reporter: Stephen L. De Rudder (sldr)
Affected Versions: 2.11.4

@scabug

This comment has been minimized.

Copy link
Author

commented Nov 7, 2014

@retronym said:
Good catch, I've fixed this for 2.11.5: scala/scala#4104

@scabug

This comment has been minimized.

Copy link
Author

commented Nov 7, 2014

Stephen L. De Rudder (sldr) said:
Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.