Skip to content
This repository
Browse code

Updated jline and rebuilt.

Two years of atrophy. Now using sbt 0.12.3 and latest
versions of jansi, etc.
  • Loading branch information...
commit 71eaf6d4e6e6163f4981b8fd0296f2daa74ba380 1 parent 5ec9dbd
Paul Phillips authored April 24, 2013
2  lib/jline.jar.desired.sha1
... ...
@@ -1 +1 @@
1  
-a5261e70728c1847639e2b47d953441d0b217bcb *jline.jar
  1
+e87ad04fdffb5cd9b7aa9293596d9fdde086eccd ?jline.jar
10  src/jline/build.sbt
@@ -4,9 +4,9 @@ name := "jline"
4 4
 
5 5
 organization := "org.scala-lang"
6 6
 
7  
-version := "2.10.0-SNAPSHOT"
  7
+version := "2.11.0-SNAPSHOT"
8 8
 
9  
-scalaVersion := "2.9.0-1"
  9
+scalaVersion := "2.10.1"
10 10
 
11 11
 // Only need these because of weird testing jline issues.
12 12
 retrieveManaged := true
@@ -14,11 +14,11 @@ retrieveManaged := true
14 14
 parallelExecution in Test := false
15 15
 
16 16
 libraryDependencies ++= Seq(
17  
-	"org.fusesource.jansi" % "jansi" % "1.4",
18  
-	"com.novocode" % "junit-interface" % "0.7" % "test->default"
  17
+	"org.fusesource.jansi" % "jansi" % "1.10",
  18
+	"com.novocode" % "junit-interface" % "0.9" % "test->default"
19 19
 )
20 20
 
21  
-javacOptions ++= Seq("-target", "1.5")
  21
+javacOptions ++= Seq("-source", "1.5", "-target", "1.5")
22 22
 
23 23
 proguardOptions ++= Seq(
24 24
   "-dontshrink",
5  src/jline/manual-test.sh
@@ -3,6 +3,7 @@
3 3
 # Apparently the jline bundled with sbt interferes with testing some
4 4
 # changes: for instance after changing the keybindings I kept seeing
5 5
 # failures until I realized what was happening and bypassed sbt, like this.
  6
+CP=lib_managed/jars/com.novocode/junit-interface/junit-interface-0.9.jar:lib_managed/jars/junit/junit-dep/junit-dep-4.8.2.jar:lib_managed/jars/org.fusesource.jansi/jansi/jansi-1.10.jar:lib_managed/jars/org.hamcrest/hamcrest-core/hamcrest-core-1.1.jar:lib_managed/jars/org.scala-tools.testing/test-interface/test-interface-0.5.jar:target/scala-2.10/test-classes:target/scala-2.10/jline_2.10-2.11.0-SNAPSHOT.min.jar
6 7
 
7  
-java -cp lib_managed/jar/com.novocode/junit-interface/junit-interface-0.5.jar:lib_managed/jar/junit/junit/junit-4.8.1.jar:lib_managed/jar/org.fusesource.jansi/jansi/jansi-1.4.jar:lib_managed/jar/org.scala-tools.testing/test-interface/test-interface-0.5.jar:target/scala-2.9.0.1/test-classes:target/scala-2.9.0.1/jline_2.9.0-1-2.10.0-SNAPSHOT.jar \
8  
-org.junit.runner.JUnitCore scala.tools.jline.console.EditLineTest
  8
+sbt proguard
  9
+java -cp $CP org.junit.runner.JUnitCore scala.tools.jline.console.EditLineTest
1  src/jline/project/build.properties
... ...
@@ -0,0 +1 @@
  1
+sbt.version=0.12.3
3  src/jline/project/plugins.sbt
... ...
@@ -0,0 +1,3 @@
  1
+resolvers += Resolver.url("sbt-plugin-releases-scalasbt", url("http://repo.scala-sbt.org/scalasbt/sbt-plugin-releases/"))(Resolver.ivyStylePatterns)
  2
+
  3
+addSbtPlugin("org.scala-sbt" % "xsbt-proguard-plugin" % "0.1.3")
5  src/jline/project/plugins/build.sbt
... ...
@@ -1,5 +0,0 @@
1  
-resolvers += "Proguard plugin repo" at "http://siasia.github.com/maven2"
2  
-
3  
-libraryDependencies <<= (libraryDependencies, appConfiguration) { (deps, app) =>
4  
-  deps :+ "com.github.siasia" %% "xsbt-proguard-plugin" % app.provider.id.version
5  
-}

0 notes on commit 71eaf6d

Please sign in to comment.
Something went wrong with that request. Please try again.