New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Failing test suite with mercurial 3.8.3 #319

Open
DimStar77 opened this Issue Jul 20, 2016 · 0 comments

Comments

Projects
None yet
1 participant
@DimStar77

DimStar77 commented Jul 20, 2016

While running hg-git's test suite against mercurial 3.8.3 the following failure occurred (master on curret git master):

[ 50s] # Running sh "/tmp/hgtests.UDcksN/child12/test-subrepos.t.sh"
[ 52s] # Ret was: False
[ 52s]
[ 52s] --- /home/abuild/rpmbuild/BUILD/hg-git-0.8.5/tests/test-subrepos.t
[ 52s] +++ /home/abuild/rpmbuild/BUILD/hg-git-0.8.5/tests/test-subrepos.t.err
[ 52s] @@ -16,11 +16,11 @@
[ 52s] $ git add alpha
[ 52s] $ fn_git_commit -m 'add alpha'
[ 52s] $ git submodule add ../gitsubrepo subrepo1
[ 52s] - Cloning into 'subrepo1'...
[ 52s] + Cloning into '$TESTTMP/gitrepo1/subrepo1'...
[ 52s] done.
[ 52s] $ fn_git_commit -m 'add subrepo1'
[ 52s] $ git submodule add ../gitsubrepo xyz/subrepo2
[ 52s] - Cloning into 'xyz/subrepo2'...
[ 52s] + Cloning into '$TESTTMP/gitrepo1/xyz/subrepo2'...
[ 52s] done.
[ 52s] $ fn_git_commit -m 'add subrepo2'
[ 52s] we are going to push to this repo from our hg clone,

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment