Skip to content
Browse files

don't specify a specific version of MSXML2.ServerXMLHTTP in wget for

compatibility with older versions of Windows
  • Loading branch information...
1 parent 124fd4b commit 1aa4d84d8c25052c042cf57736318e09e8060ee1 @schisamo committed Oct 28, 2011
Showing with 3 additions and 3 deletions.
  1. +3 −3 lib/chef/knife/core/windows_bootstrap_context.rb
View
6 lib/chef/knife/core/windows_bootstrap_context.rb
@@ -26,9 +26,9 @@ module Core
# following instance variables:
# * @config - a hash of knife's config values
# * @run_list - the run list for the node to boostrap
- #
+ #
class WindowsBootstrapContext < BootstrapContext
-
+
def initialize(config, run_list, chef_config)
@config = config
@run_list = run_list
@@ -91,7 +91,7 @@ def win_wget
win_wget = <<-WGET
url = WScript.Arguments.Named("url")
path = WScript.Arguments.Named("path")
-Set objXMLHTTP = CreateObject("MSXML2.ServerXMLHTTP.6.0")
+Set objXMLHTTP = CreateObject("MSXML2.ServerXMLHTTP")
Set wshShell = CreateObject( "WScript.Shell" )
Set objUserVariables = wshShell.Environment("USER")

0 comments on commit 1aa4d84

Please sign in to comment.
Something went wrong with that request. Please try again.