Permalink
Browse files

Initial commit

  • Loading branch information...
schneems committed Apr 12, 2011
0 parents commit 0a065ccce50b35bce423b50cd6ba3fe62321184b
Showing with 10,839 additions and 0 deletions.
  1. +4 −0 .gitignore
  2. +19 −0 .rvmrc
  3. +36 −0 Gemfile
  4. +102 −0 Gemfile.lock
  5. +256 −0 README
  6. +7 −0 Rakefile
  7. +15 −0 app/controllers/application_controller.rb
  8. +21 −0 app/controllers/friendships_controller.rb
  9. +24 −0 app/controllers/user_sessions_controller.rb
  10. +35 −0 app/controllers/users_controller.rb
  11. +2 −0 app/helpers/application_helper.rb
  12. +2 −0 app/helpers/user_sessions_helper.rb
  13. +2 −0 app/helpers/users_helper.rb
  14. +55 −0 app/models/friendship.rb
  15. +20 −0 app/models/user.rb
  16. +2 −0 app/models/user_session.rb
  17. +24 −0 app/views/layouts/application.html.erb
  18. +17 −0 app/views/user_sessions/new.html.erb
  19. +10 −0 app/views/users/_user.html.erb
  20. +2 −0 app/views/users/edit.html.erb
  21. +5 −0 app/views/users/index.html.erb
  22. +2 −0 app/views/users/new.html.erb
  23. +4 −0 config.ru
  24. +42 −0 config/application.rb
  25. +6 −0 config/boot.rb
  26. +22 −0 config/database.yml
  27. +5 −0 config/environment.rb
  28. +26 −0 config/environments/development.rb
  29. +49 −0 config/environments/production.rb
  30. +35 −0 config/environments/test.rb
  31. +7 −0 config/initializers/backtrace_silencers.rb
  32. +10 −0 config/initializers/inflections.rb
  33. +18 −0 config/initializers/memcache.rb
  34. +5 −0 config/initializers/mime_types.rb
  35. +3 −0 config/initializers/redis.rb
  36. +7 −0 config/initializers/secret_token.rb
  37. +8 −0 config/initializers/session_store.rb
  38. +5 −0 config/locales/en.yml
  39. +76 −0 config/routes.rb
  40. +16 −0 db/migrate/20110406233027_create_users.rb
  41. +13 −0 db/migrate/20110407002239_friendships.rb
  42. +31 −0 db/schema.rb
  43. +7 −0 db/seeds.rb
  44. +2 −0 doc/README_FOR_APP
  45. 0 lib/tasks/.gitkeep
  46. +26 −0 public/404.html
  47. +26 −0 public/422.html
  48. +26 −0 public/500.html
  49. 0 public/favicon.ico
  50. BIN public/images/rails.png
  51. +2 −0 public/javascripts/application.js
  52. +965 −0 public/javascripts/controls.js
  53. +974 −0 public/javascripts/dragdrop.js
  54. +1,123 −0 public/javascripts/effects.js
  55. +6,001 −0 public/javascripts/prototype.js
  56. +191 −0 public/javascripts/rails.js
  57. +5 −0 public/robots.txt
  58. 0 public/stylesheets/.gitkeep
  59. +363 −0 public/stylesheets/pot_friends.css
  60. +6 −0 script/rails
  61. +11 −0 test/fixtures/users.yml
  62. +9 −0 test/functional/user_sessions_controller_test.rb
  63. +14 −0 test/functional/users_controller_test.rb
  64. +9 −0 test/performance/browsing_test.rb
  65. +13 −0 test/test_helper.rb
  66. +4 −0 test/unit/helpers/user_sessions_helper_test.rb
  67. +4 −0 test/unit/helpers/users_helper_test.rb
  68. +8 −0 test/unit/user_test.rb
  69. 0 vendor/plugins/.gitkeep
@@ -0,0 +1,4 @@
+.bundle
+db/*.sqlite3
+log/*.log
+tmp/
19 .rvmrc
@@ -0,0 +1,19 @@
+#!/usr/bin/env bash
+
+ruby_string="ree-1.8.7-2011.03"
+gemset_name="potential_friend_finder"
+
+if rvm list strings | grep -q "${ruby_string}" ; then
+
+ rvm use "${ruby_string}@${gemset_name}" --create
+
+ # Complain if bundler isn't installed
+ if [[ -z "`gem which bundler 2>&1 | grep -v ERROR`" ]]; then
+ echo "You need bundler:"
+ echo ""
+ echo " gem install bundler"
+ echo ""
+ fi
+else
+ echo "${ruby_string} was not found, please run 'rvm install ${ruby_string}' and then cd back into the project directory."
+fi
36 Gemfile
@@ -0,0 +1,36 @@
+source 'http://rubygems.org'
+
+gem 'rails', '3.0.5'
+
+gem 'dynamic_form'
+gem 'authlogic'
+gem 'memcached'
+gem 'redis', '1.0.6'
+
+# Bundle edge Rails instead:
+# gem 'rails', :git => 'git://github.com/rails/rails.git'
+
+gem 'sqlite3'
+
+# Use unicorn as the web server
+# gem 'unicorn'
+
+# Deploy with Capistrano
+gem 'capistrano'
+
+# To use debugger (ruby-debug for Ruby 1.8.7+, ruby-debug19 for Ruby 1.9.2+)
+# gem 'ruby-debug'
+# gem 'ruby-debug19', :require => 'ruby-debug'
+
+# Bundle the extra gems:
+# gem 'bj'
+# gem 'nokogiri'
+# gem 'sqlite3-ruby', :require => 'sqlite3'
+# gem 'aws-s3', :require => 'aws/s3'
+
+# Bundle gems for the local environment. Make sure to
+# put test-only gems in this group so their generators
+# and rake tasks are available in development mode:
+# group :development, :test do
+# gem 'webrat'
+# end
@@ -0,0 +1,102 @@
+GEM
+ remote: http://rubygems.org/
+ specs:
+ abstract (1.0.0)
+ actionmailer (3.0.5)
+ actionpack (= 3.0.5)
+ mail (~> 2.2.15)
+ actionpack (3.0.5)
+ activemodel (= 3.0.5)
+ activesupport (= 3.0.5)
+ builder (~> 2.1.2)
+ erubis (~> 2.6.6)
+ i18n (~> 0.4)
+ rack (~> 1.2.1)
+ rack-mount (~> 0.6.13)
+ rack-test (~> 0.5.7)
+ tzinfo (~> 0.3.23)
+ activemodel (3.0.5)
+ activesupport (= 3.0.5)
+ builder (~> 2.1.2)
+ i18n (~> 0.4)
+ activerecord (3.0.5)
+ activemodel (= 3.0.5)
+ activesupport (= 3.0.5)
+ arel (~> 2.0.2)
+ tzinfo (~> 0.3.23)
+ activeresource (3.0.5)
+ activemodel (= 3.0.5)
+ activesupport (= 3.0.5)
+ activesupport (3.0.5)
+ arel (2.0.9)
+ authlogic (2.1.6)
+ activesupport
+ builder (2.1.2)
+ capistrano (2.5.20)
+ highline
+ highline
+ net-scp (>= 1.0.0)
+ net-scp
+ net-sftp
+ net-sftp (>= 2.0.0)
+ net-ssh (>= 2.0.14)
+ net-ssh
+ net-ssh-gateway
+ net-ssh-gateway (>= 1.0.0)
+ dynamic_form (1.1.3)
+ erubis (2.6.6)
+ abstract (>= 1.0.0)
+ highline (1.6.1)
+ i18n (0.5.0)
+ mail (2.2.15)
+ activesupport (>= 2.3.6)
+ i18n (>= 0.4.0)
+ mime-types (~> 1.16)
+ treetop (~> 1.4.8)
+ memcached (1.2.5)
+ mime-types (1.16)
+ net-scp (1.0.4)
+ net-ssh (>= 1.99.1)
+ net-sftp (2.0.5)
+ net-ssh (>= 2.0.9)
+ net-ssh (2.1.4)
+ net-ssh-gateway (1.0.1)
+ net-ssh (>= 1.99.1)
+ polyglot (0.3.1)
+ rack (1.2.2)
+ rack-mount (0.6.14)
+ rack (>= 1.0.0)
+ rack-test (0.5.7)
+ rack (>= 1.0)
+ rails (3.0.5)
+ actionmailer (= 3.0.5)
+ actionpack (= 3.0.5)
+ activerecord (= 3.0.5)
+ activeresource (= 3.0.5)
+ activesupport (= 3.0.5)
+ bundler (~> 1.0)
+ railties (= 3.0.5)
+ railties (3.0.5)
+ actionpack (= 3.0.5)
+ activesupport (= 3.0.5)
+ rake (>= 0.8.7)
+ thor (~> 0.14.4)
+ rake (0.8.7)
+ redis (1.0.6)
+ sqlite3 (1.3.3)
+ thor (0.14.6)
+ treetop (1.4.9)
+ polyglot (>= 0.3.1)
+ tzinfo (0.3.26)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ authlogic
+ capistrano
+ dynamic_form
+ memcached
+ rails (= 3.0.5)
+ redis (= 1.0.6)
+ sqlite3
Oops, something went wrong.

0 comments on commit 0a065cc

Please sign in to comment.