test_setup.py does not actually prevent multiprocessing #841

Closed
vene opened this Issue May 7, 2012 · 5 comments

Comments

Projects
None yet
4 participants
@vene
Member

vene commented May 7, 2012

Ok, so I thought I had fixed this, but I had not.

2b287c3

This has no effect, I got fooled by having manually set the environment variable as well.

Since this is windows-only, a hack would be to do something like system('set VAR_NAME=0') instead and see if it works.

@amueller

This comment has been minimized.

Show comment
Hide comment
@amueller

amueller Jul 26, 2013

Member

@vene can we close that? or can we fix it? I'm not entirely sure about this issue.

Member

amueller commented Jul 26, 2013

@vene can we close that? or can we fix it? I'm not entirely sure about this issue.

@vene

This comment has been minimized.

Show comment
Hide comment
@vene

vene Jul 26, 2013

Member

Not sure, I think it's still an issue, but not a major one. It makes tests
hard to run on Windows (sometimes?).

On Fri, Jul 26, 2013 at 11:15 AM, Andreas Mueller
notifications@github.comwrote:

@vene https://github.com/vene can we close that? or can we fix is? I'm
not entirely sure about this issue.


Reply to this email directly or view it on GitHubhttps://github.com/scikit-learn/scikit-learn/issues/841#issuecomment-21609943
.

Member

vene commented Jul 26, 2013

Not sure, I think it's still an issue, but not a major one. It makes tests
hard to run on Windows (sometimes?).

On Fri, Jul 26, 2013 at 11:15 AM, Andreas Mueller
notifications@github.comwrote:

@vene https://github.com/vene can we close that? or can we fix is? I'm
not entirely sure about this issue.


Reply to this email directly or view it on GitHubhttps://github.com/scikit-learn/scikit-learn/issues/841#issuecomment-21609943
.

@GaelVaroquaux

This comment has been minimized.

Show comment
Hide comment
@GaelVaroquaux

GaelVaroquaux Jul 26, 2013

Member

Not sure, I think it's still an issue, but not a major one. It makes tests hard to run on Windows (sometimes?).

Joblib got significantly improved with regards to that. Do you have time
to test that it is still an issue?

Member

GaelVaroquaux commented Jul 26, 2013

Not sure, I think it's still an issue, but not a major one. It makes tests hard to run on Windows (sometimes?).

Joblib got significantly improved with regards to that. Do you have time
to test that it is still an issue?

@amueller

This comment has been minimized.

Show comment
Hide comment
@amueller

amueller Jul 28, 2013

Member

how to test this?

Member

amueller commented Jul 28, 2013

how to test this?

@amueller amueller modified the milestones: 0.15.1, 0.15 Jul 18, 2014

@amueller amueller removed this from the 0.16 milestone Mar 5, 2015

@amueller amueller modified the milestone: 0.19 Sep 29, 2016

@jnothman

This comment has been minimized.

Show comment
Hide comment
@jnothman

jnothman Jun 14, 2017

Member

I'm going to presume this is no longer relevant.

Member

jnothman commented Jun 14, 2017

I'm going to presume this is no longer relevant.

@jnothman jnothman closed this Jun 14, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment