Skip to content

Plugin to use Gautomatch program within the Scipion framework

License

Notifications You must be signed in to change notification settings

scipion-em/scipion-em-gautomatch

Repository files navigation

Gautomatch plugin

This plugin provides a wrapper for Gautomatch picker.

PyPI release

License

Supported Python versions

SonarCloud quality gate

Downloads

Installation

You will need to use 3.0+ version of Scipion to be able to run these protocols. To install the plugin, you have two options:

  1. Stable version

    scipion installp -p scipion-em-gautomatch
  2. Developer's version

    • download repository
    git clone -b devel https://github.com/scipion-em/scipion-em-gautomatch.git
    • install
    scipion installp -p /path/to/scipion-em-gautomatch --devel

Gautomatch binaries will be installed automatically with the plugin, but you can also link an existing installation. Default installation path assumed is software/em/gautomatch-0.56, if you want to change it, set GAUTOMATCH_HOME in scipion.conf file to the folder where the Gautomatch is installed. Depending on your CUDA version and GPU card compute capability you might want to change the default binary from Gautomatch_v0.56_sm30-75_cu10.1 to a different one by explicitly setting GAUTOMATCH variable. If you need to use CUDA different from the one used during Scipion installation (defined by CUDA_LIB), you can add GAUTOMATCH_CUDA_LIB variable to the config file. Various binaries can be downloaded from the official Gautomatch website.

To check the installation, simply run the following Scipion test:

scipion test gautomatch.tests.test_protocols_gautomatch.TestGautomatchAutomaticPicking

Supported versions

0.53 and 0.56

Protocols

References

  1. Kai Zhang. Unpublished.