Permalink
Browse files

MAINT: raise more informative error when importing weave under Python…

… 3.x

Submitted as PR-268, but not reviewed.  Committing now to get it in for 0.11.0.
  • Loading branch information...
1 parent d0e24ee commit c2e8029054e7fbb8083b11996398db8634a8b564 @rgommers rgommers committed Jul 15, 2012
Showing with 6 additions and 0 deletions.
  1. +6 −0 scipy/weave/__init__.py
View
@@ -16,6 +16,12 @@
"""
+import sys
+
+if sys.version_info[0] >= 3:
+ raise ImportError("scipy.weave only supports Python 2.x")
+
+
from weave_version import weave_version as __version__
try:

0 comments on commit c2e8029

Please sign in to comment.