Skip to content
Browse files

DOC: document that support for Python 2.4 and 2.5 has been dropped fo…

…r 0.12.x
  • Loading branch information...
1 parent 785491c commit ea471124581ffebdb3e2efa1183a4cf0bbc9623d @rgommers rgommers committed Dec 26, 2012
Showing with 5 additions and 4 deletions.
  1. +1 −1 INSTALL.txt
  2. +2 −1 doc/release/0.12.0-notes.rst
  3. +2 −2 tox.ini
View
2 INSTALL.txt
@@ -27,7 +27,7 @@ PREREQUISITES
SciPy requires the following software installed for your platform:
-1) Python__ 2.4.x or newer
+1) Python__ 2.6.x or newer
__ http://www.python.org
View
3 doc/release/0.12.0-notes.rst
@@ -15,7 +15,8 @@ of bug-fixes and optimizations. Moreover, our development attention
will now shift to bug-fix releases on the 0.12.x branch, and on adding
new features on the master branch.
-This release requires Python 2.4-2.7 or 3.1- and NumPy 1.X.X or greater.
+This release requires Python 2.6, 2.7 or 3.1-3.3 and NumPy 1.5.1 or greater.
+Support for Python 2.4 and 2.5 has been dropped as of this release.
New features
View
4 tox.ini
@@ -22,11 +22,11 @@
# tox -- -v
# Tox assumes that you have appropriate Python interpreters already
-# installed and that they can be run as 'python2.4', 'python2.5', etc.
+# installed and that they can be run as 'python2.6', 'python2.7', etc.
[tox]
toxworkdir = {homedir}/.tox/scipy/
-envlist = py24,py25,py26,py27,py31,py32
+envlist = py26,py27,py31,py32,py33
[testenv]
deps=

0 comments on commit ea47112

Please sign in to comment.
Something went wrong with that request. Please try again.