Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

scipy svn does not compile (Trac #989) #1516

Closed
scipy-gitbot opened this Issue Apr 25, 2013 · 3 comments

Comments

Projects
None yet
1 participant

Original ticket http://projects.scipy.org/scipy/ticket/989 on 2009-08-22 by trac user olenz, assigned to unknown.

I'm using up-to-date Kubuntu Linux 9.04. When I try to compile the current SVN of SciPy, I get:

Traceback (most recent call last):
File "setup.py", line 160, in
setup_package()
File "setup.py", line 152, in setup_package
configuration=configuration )
File "/usr/lib/python2.6/dist-packages/numpy/distutils/core.py", line 150, in setup
config = configuration()
File "setup.py", line 118, in configuration
config.add_subpackage('scipy')
File "/usr/lib/python2.6/dist-packages/numpy/distutils/misc_util.py", line 851, in add_subpackage
caller_level = 2)
File "/usr/lib/python2.6/dist-packages/numpy/distutils/misc_util.py", line 834, in get_subpackage
caller_level = caller_level + 1)
File "/usr/lib/python2.6/dist-packages/numpy/distutils/misc_util.py", line 781, in _get_configuration_from_setup_py
config = setup_module.configuration(*args)
File "scipy/setup.py", line 20, in configuration
config.add_subpackage('special')
File "/usr/lib/python2.6/dist-packages/numpy/distutils/misc_util.py", line 851, in add_subpackage
caller_level = 2)
File "/usr/lib/python2.6/dist-packages/numpy/distutils/misc_util.py", line 834, in get_subpackage
caller_level = caller_level + 1)
File "/usr/lib/python2.6/dist-packages/numpy/distutils/misc_util.py", line 766, in _get_configuration_from_setup_py
('.py', 'U', 1))
File "scipy/special/setup.py", line 7, in
from numpy.distutils.misc_util import get_numpy_include_dirs, get_info
ImportError: cannot import name get_info

trac user olenz wrote on 2009-08-22

Ok, issue is solved. I was not using svn numpy.
Issue can be closed.

trac user rspeer wrote on 2009-09-01

Well, it's still a documentation issue. I just ran into this, and didn't think I needed SVN NumPy because the INSTALL.txt said I only needed Numpy 1.3.0.

@rgommers wrote on 2010-05-08

Added note to INSTALL.txt to clarify this point.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment