Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

MAINT: add install_requires to setup.py #465

Closed
wants to merge 1 commit into from

2 participants

@pv
Owner
pv commented

Tell pip and other tools that Numpy is required before build.

@pv
Owner
pv commented

@rgommers: I thought there was some reason why it wasn't there, hence via PR... So the reason is that -U in easy_install and pip also causes upgrade of Numpy which can break stuff? Pip seems to have been fixed: pypa/pip#571 EDIT: or, actually not.

@rgommers
Owner

Correct. And indeed, that pip PR is not in. sadly....

@pv pv closed this
@ClemensFMN ClemensFMN referenced this pull request from a commit
Commit has since been removed from the repository and is no longer available.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Mar 12, 2013
  1. @pv
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 0 deletions.
  1. +1 −0  setup.py
View
1  setup.py
@@ -179,6 +179,7 @@ def setup_package():
license = 'BSD',
classifiers=[_f for _f in CLASSIFIERS.split('\n') if _f],
platforms = ["Windows", "Linux", "Solaris", "Mac OS-X", "Unix"],
+ install_requires=['numpy>=1.5.0'],
)
if len(sys.argv) >= 2 and ('--help' in sys.argv[1:] or
Something went wrong with that request. Please try again.