MAINT: fix Python 3 syntax errors in scipy.weave #466

Merged
merged 2 commits into from Mar 24, 2013

Conversation

Projects
None yet
2 participants
Owner

pv commented Mar 12, 2013

It's still not a port to Python 3, but probably makes the fedora people happier: http://projects.scipy.org/scipy/ticket/1843

pv added some commits Mar 12, 2013

MAINT: weave: fix Python 3 syntax errors
The weave module doesn't work on Python 3, but these changes at least
make its syntax compatible, so that no SyntaxErrors arise on build.

2to3 fixers used: print, import, repr, exec, except
Added from __future__ import absolute_import, print_function
on top.
Owner

rgommers commented Mar 24, 2013

Merging, thanks @pv.

rgommers added a commit that referenced this pull request Mar 24, 2013

Merge pull request #466 from pv/weave-syntaxerror3
MAINT: fix Python 3 syntax errors in scipy.weave

@rgommers rgommers merged commit a66d4af into scipy:master Mar 24, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment