Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Scala 2.13.0-M4 #119

Closed
wants to merge 1 commit into from

Conversation

@xuwei-k
Copy link
Contributor

commented Jul 5, 2018

No description provided.

mimaBinaryIssueFilters ++= Seq(
ProblemFilters.exclude[IncompatibleMethTypeProblem]("scodec.DecoderFunctions.decodeCollect"),

This comment has been minimized.

Copy link
@mpilquist

mpilquist Jul 10, 2018

Contributor

Hm, these are real binary incompatibilities, right? Requiring us to release scodec-core 1.11?

This comment has been minimized.

Copy link
@xuwei-k

xuwei-k Jul 13, 2018

Author Contributor

Yes real binary incompatibilities 😥

This comment has been minimized.

Copy link
@smarter

smarter Sep 5, 2018

scala-collection-compat 0.2.0 has been released which should solve the binary incompatibilities: scala/scala-collection-compat#115

@@ -8,9 +8,9 @@ cache:
language: scala

scala:
- 2.10.6

This comment has been minimized.

Copy link
@xuwei-k

xuwei-k Jul 13, 2018

Author Contributor

We can't continue Scala 2.10 support if use scala-collection-compat scala/scala-collection-compat#1

@xuwei-k

This comment has been minimized.

Copy link
Contributor Author

commented Jul 13, 2018

binary compatible version. but some tricky hacks.
xuwei-k@84e5f30

@mpilquist

This comment has been minimized.

Copy link
Contributor

commented Jul 14, 2018

Wow, awesome! Normally I'd prefer the backwards compatible version but in this case, I'm thinking we release scodec 1.11.0-M1 and drop 2.10 support. That way we don't need our own version of CanBuildFrom. Also, Shapeless is dropping 2.10 support soon as well. What do you think?

@milessabin

This comment has been minimized.

Copy link

commented Jul 15, 2018

FYI: shapeless support for 2.10 will continue for 2.3.x ... I won't be dropping 2.10 support until 2.4.0.

@mpilquist

This comment has been minimized.

Copy link
Contributor

commented Sep 26, 2018

Not really sure how to proceed here. I think we should maintain 2.13 support on a branch until the final release, so as to avoid introducing binary compatibility problems on the 2.11 or 2.12 builds as a result of changes in scala-collection-compat.

@xuwei-k xuwei-k force-pushed the xuwei-k:2.13.0-M4 branch from d7deb3b to f8581e7 Oct 13, 2018

@mpilquist

This comment has been minimized.

Copy link
Contributor

commented Jan 21, 2019

Merged as part of #138

@mpilquist mpilquist closed this Jan 21, 2019

@xuwei-k xuwei-k deleted the xuwei-k:2.13.0-M4 branch Jan 23, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.