New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

404 https://atlas.hashicorp.com/scotch/box #367

Closed
GavinJaynes opened this Issue Feb 5, 2018 · 6 comments

Comments

Projects
None yet
5 participants
@GavinJaynes
Copy link

GavinJaynes commented Feb 5, 2018

Hi - when installing ( vagrant up ) I get the following error:

The box 'scotch/box' could not be found or
could not be accessed in the remote catalog. If this is a private
box on HashiCorp's Atlas, please verify you're logged in via
vagrant login. Also, please double-check the name. The expanded
URL and error message are shown below:

URL: ["https://atlas.hashicorp.com/scotch/box"]
Error: The requested URL returned error: 404 Not Found

Please help - much appreciated

@temp1029

This comment has been minimized.

Copy link

temp1029 commented Feb 6, 2018

Getting the same thing here but on Pro version. Didn't see an issue there so tacking it onto this one here.

@whatnickcodes

This comment has been minimized.

Copy link
Member

whatnickcodes commented Feb 6, 2018

Looks like Vagrant Cloud bug

But it looks like Vagrant people are killing off the atlas.hashicorp domain and it's causing Hell for everyone.

For example, this is the URL you want: https://app.vagrantup.com/scotch/box

This is the direct link:

https://app.vagrantup.com/scotch/boxes/box/versions/3.0/providers/virtualbox.box

@whatnickcodes

This comment has been minimized.

Copy link
Member

whatnickcodes commented Feb 6, 2018

Jeeze:

Here's a work around: hashicorp/vagrant#9442 (comment)

@whatnickcodes

This comment has been minimized.

Copy link
Member

whatnickcodes commented Feb 6, 2018

Also for anyone else.

Maybe just destroy and remove all boxes. The old URL might be saved in the meta and there's no redirect in place

Remove Vagrant completely, re-install the latest version.

@geckoseo

This comment has been minimized.

Copy link

geckoseo commented Feb 28, 2018

All I did was add the box again manually using the new location and it flushed out the old meta..

I didn't even need to shut the machine down first, and when I reloaded it the errors were gone.

@jayhill90

This comment has been minimized.

Copy link

jayhill90 commented Mar 3, 2018

Adding Vagrant::DEFAULT_SERVER_URL.replace('https://vagrantcloud.com') to the Vagrantfile works.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment