Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

ripCSS base tag issue #103

Closed
rcdarwin opened this Issue Feb 3, 2012 · 2 comments

Comments

Projects
None yet
3 participants

rcdarwin commented Feb 3, 2012

On line 80 of respond.src.js, the !base check fails when the document has a base tag. Because it fails, the second part of the && never evaluates. This causes the RegExp.$1 in the ¦¦ to be undefined, which causes that test to fail. The end result is that the requestQueue is never populated and @media queries on the page are ignored. I am using IE8.

Switching the order of the expressions in the && test fixed this for me.

Owner

scottjehl commented Feb 4, 2012

hmm @doctyper - thoughts?

On Feb 4, 2012, at 1:38 AM, rcdarwin wrote:

On line 80 of respond.src.is, the !base check fails when the document has a tag. Because it fails, the second part of the && never evaluates. This causes the RegExp.$1 in the ¦¦ to be undefined, which causes that test to fail. The end result is that the requestQueue is never populated and @media queries on the page are ignored. I am using IE8.

Switching the order of the expressions in the && test fixed this for me.


Reply to this email directly or view it on GitHub:
#103

Collaborator

doctyper commented Feb 4, 2012

Works for me.

@scottjehl scottjehl closed this in fd892e1 Feb 4, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment