New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support Django 1.8 & 1.9 #26

Open
cschneid opened this Issue Apr 18, 2018 · 9 comments

Comments

Projects
None yet
7 participants
@cschneid
Contributor

cschneid commented Apr 18, 2018

No description provided.

@sebzur

This comment has been minimized.

sebzur commented May 22, 2018

@cschneid Any estimated deadline for this issue?

@dlanderson

This comment has been minimized.

Contributor

dlanderson commented May 23, 2018

@sebzur No ETA at the moment. We'll update the issue if that changes. What frameworks+versions+app servers do you use?

@mtthwsar

This comment has been minimized.

mtthwsar commented Jun 21, 2018

This would be useful for me too!

@ckcollab

This comment has been minimized.

ckcollab commented Aug 24, 2018

Thanks for all of the hard work on this! I was bummed to get through setup and realize Django 2.0 isn't supported; hope this works soon.

@itsderek23

This comment has been minimized.

Member

itsderek23 commented Aug 24, 2018

Hi @ckcollab - odd. Scout scout support Django 2.0.

Mind emailing support@scoutapp.com with any errors you are seeing?

@ckcollab

This comment has been minimized.

ckcollab commented Aug 24, 2018

Ah, misread the readme, hopefully it's a simple mistake on my end! Here's the error:

       Traceback (most recent call last):
         File "manage.py", line 15, in <module>
           execute_from_command_line(sys.argv)
         File "/app/.heroku/python/lib/python3.6/site-packages/django/core/management/__init__.py", line 371, in execute_from_command_line
           utility.execute()
         File "/app/.heroku/python/lib/python3.6/site-packages/django/core/management/__init__.py", line 347, in execute
           django.setup()
         File "/app/.heroku/python/lib/python3.6/site-packages/django/__init__.py", line 24, in setup
           apps.populate(settings.INSTALLED_APPS)
         File "/app/.heroku/python/lib/python3.6/site-packages/django/apps/registry.py", line 120, in populate
           app_config.ready()
         File "/app/.heroku/python/lib/python3.6/site-packages/scout_apm/django/apps.py", line 30, in ready
           self.install_middleware()
         File "/app/.heroku/python/lib/python3.6/site-packages/scout_apm/django/apps.py", line 44, in install_middleware
           if settings.MIDDLEWARE_CLASSES is not None:
         File "/app/.heroku/python/lib/python3.6/site-packages/django/conf/__init__.py", line 57, in __getattr__
           val = getattr(self._wrapped, name)
       AttributeError: 'Settings' object has no attribute 'MIDDLEWARE_CLASSES'

I can open a new issue for this?

@cschneid

This comment has been minimized.

Contributor

cschneid commented Aug 24, 2018

@ckcollab I'll open an issue and get that fixed. Sorry!

@cschneid

This comment has been minimized.

Contributor

cschneid commented Aug 24, 2018

@ckcollab the issue is #118, and I just pushed a PR for it to #119

It'll be released in a little bit as version 1.3.2

EDIT Fixed version number.

@ajford

This comment has been minimized.

ajford commented Sep 5, 2018

Also would love to see Django 1.8/1.9 support.

Django 1.8 on Ubuntu 16.04 running behind uwsgi, if details help.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment