Scrapy, a fast high-level web crawling & scraping framework for Python.
dangra Merge pull request #3445 from jfflisikowski/3097-item-urls-not-define…
…d-in-example

[MRG+1] Updating debug example file (#3097)
Latest commit 06f2db7 Oct 16, 2018
Permalink
Failed to load latest commit information.
artwork Use https for external links wherever possible in docs Oct 26, 2017
debian Use https links wherever possible Oct 28, 2017
docs Correct the unclear comments by adding <# < processing code not shown > Oct 2, 2018
extras Use https for external links wherever possible in docs Oct 26, 2017
scrapy DOC use autodocs for selectors; document more methods and attributes;… Sep 12, 2018
sep Fix link for 'XPath and XSLT with lxml' Oct 28, 2017
tests DOC address @stummjr's review comments Sep 18, 2018
.bumpversion.cfg Bump version: 1.4.0 → 1.5.0 Dec 29, 2017
.coveragerc remove ancient modules kept only for error messages Jul 5, 2018
.gitignore add pytest temp files to gitignore Sep 12, 2018
.travis.yml Try to get python3.7 by using xenial base and sudo Jul 9, 2018
AUTHORS added Nicolas Ramirez to AUTHORS Mar 14, 2013
CODE_OF_CONDUCT.md minor grammatical fixes in CODE_OF_CONDUCT.md Jun 2, 2018
CONTRIBUTING.md Use https links wherever possible Oct 28, 2017
INSTALL Use https links wherever possible Oct 28, 2017
LICENSE added oxford commas to LICENSE Jun 2, 2018
MANIFEST.in Ignore explicitly compiled python files. Nov 8, 2016
Makefile.buildbot Generated version as pep440 and dpkg compatible Jun 16, 2015
NEWS added NEWS file pointing to docs/news.rst Apr 29, 2012
README.rst Drop support for EOL Python 3.3 Dec 19, 2017
appveyor.yml Cache pip cache and do not rebuild tags on appveyor and travis Aug 15, 2018
codecov.yml codecov config: disable project check, tweak PR comments May 18, 2017
conftest.py remove ancient modules kept only for error messages Jul 5, 2018
pytest.ini Don't collect tests by their class name May 4, 2015
requirements-py2.txt require parsel 1.5+ Sep 12, 2018
requirements-py3.txt require parsel 1.5+ Sep 12, 2018
setup.cfg Build universal wheels Mar 1, 2016
setup.py require parsel 1.5+ Sep 12, 2018
tox.ini Merge branch 'master' of https://github.com/patiences/scrapy into pat… Jul 9, 2018

README.rst

Scrapy

PyPI Version Supported Python Versions Build Status Wheel Status Coverage report Conda Version

Overview

Scrapy is a fast high-level web crawling and web scraping framework, used to crawl websites and extract structured data from their pages. It can be used for a wide range of purposes, from data mining to monitoring and automated testing.

For more information including a list of features check the Scrapy homepage at: https://scrapy.org

Requirements

  • Python 2.7 or Python 3.4+
  • Works on Linux, Windows, Mac OSX, BSD

Install

The quick way:

pip install scrapy

For more details see the install section in the documentation: https://doc.scrapy.org/en/latest/intro/install.html

Documentation

Documentation is available online at https://doc.scrapy.org/ and in the docs directory.

Releases

You can find release notes at https://doc.scrapy.org/en/latest/news.html

Community (blog, twitter, mail list, IRC)

See https://scrapy.org/community/

Contributing

See https://doc.scrapy.org/en/master/contributing.html

Code of Conduct

Please note that this project is released with a Contributor Code of Conduct (see https://github.com/scrapy/scrapy/blob/master/CODE_OF_CONDUCT.md).

By participating in this project you agree to abide by its terms. Please report unacceptable behavior to opensource@scrapinghub.com.

Companies using Scrapy

See https://scrapy.org/companies/

Commercial Support

See https://scrapy.org/support/