Permalink
Browse files

make sure to install FluentDOM before testing

  • Loading branch information...
1 parent e451830 commit 3908c138720271916d0932740495fd205b679436 @scribu committed Feb 21, 2013
Showing with 4 additions and 2 deletions.
  1. +4 −1 .travis.yml
  2. +0 −1 composer.json
View
@@ -14,16 +14,19 @@ before_install:
- git submodule update --init --recursive
before_script:
+ # install dependencies
+ - curl -sS https://getcomposer.org/installer | php
+ - php composer.phar install --dev
# set up WP install
- WP_CORE_DIR=/tmp/wordpress/
- wget -nv -O /tmp/wordpress.tar.gz https://github.com/WordPress/WordPress/tarball/$WP_VERSION
- mkdir -p $WP_CORE_DIR
- tar --strip-components=1 -zxmf /tmp/wordpress.tar.gz -C $WP_CORE_DIR
+ # set up testing suite
- plugin_slug=$(basename $(pwd))
- plugin_dir=$WP_CORE_DIR/wp-content/plugins/$plugin_slug
- cd ..
- mv $plugin_slug $plugin_dir
- # set up testing suite
- export WP_TESTS_DIR=/tmp/wordpress-tests/
- svn co --ignore-externals --quiet http://unit-tests.svn.wordpress.org/trunk/ $WP_TESTS_DIR
- cd $WP_TESTS_DIR
View
@@ -4,7 +4,6 @@
"php": ">=5.2"
},
"require-dev": {
- "phpunit/phpunit": "3.7.x",
"fluentdom/fluentdom": "dev-master"
},
"minimum-stability": "dev"

0 comments on commit 3908c13

Please sign in to comment.