Permalink
Browse files

aws-tools-0 +ami +api

  • Loading branch information...
1 parent 33b8ec9 commit af78d276794833484b8dacfadfc6278ae00f338c @scrill committed Feb 24, 2012
View
84 README.md
@@ -14,73 +14,73 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
reprepro {
version => "4.3.0-r1",
description => "Debian repository creator and maintainer application",
- homepage => " http://packages.debian.org/reprepro"
+ homepage => "http://packages.debian.org/reprepro"
}
aws-sns-tools {
version => "1.0.2.3",
description => "Command Line Interface Tool for Amazon Simple Notification Service",
- homepage => " http://aws.amazon.com/developertools/3688"
+ homepage => "http://aws.amazon.com/developertools/3688"
}
aws-cw-tools {
version => "1.0.12.1",
description => "The API tools serve as the client interface to the Amazon CloudWatch web service",
- homepage => " http://aws.amazon.com/developertools/2534"
+ homepage => "http://aws.amazon.com/developertools/2534"
}
aws-elb-tools {
version => "1.0.15.1",
description => "The API tools serve as the client interface to the Elastic Load Balancing web service",
- homepage => " http://aws.amazon.com/developertools/Amazon-EC2/2536"
+ homepage => "http://aws.amazon.com/developertools/Amazon-EC2/2536"
}
aws-as-tools {
version => "1.0.49.1",
description => "The API tools serve as the client interface to the Auto Scaling web service",
- homepage => " http://aws.amazon.com/developertools/2535"
+ homepage => "http://aws.amazon.com/developertools/2535"
}
aws-cfn-tools {
version => "1.0.9",
description => "The command line tools serve as the client interface to the AWS CloudFormation web service",
- homepage => " http://aws.amazon.com/developertools/AWS-CloudFormation/2555753788650372"
+ homepage => "http://aws.amazon.com/developertools/AWS-CloudFormation/2555753788650372"
}
puppet-lint {
version => "0.1.12",
description => "Checks your Puppet manifests against the Puppetlabs style guide and alerts you to any discrepancies",
- homepage => " https://github.com/rodjek/puppet-lint"
+ homepage => "https://github.com/rodjek/puppet-lint"
}
aws-rds-tools {
version => "1.6.001",
description => "The Command Line Toolkit for the Amazon Relational Database Service",
- homepage => " http://aws.amazon.com/developertools/2928"
+ homepage => "http://aws.amazon.com/developertools/2928"
}
puppet-module {
version => "0.3.4",
description => "The Puppet Module Tool creates, installs and searches for Puppet modules",
- homepage => " https://github.com/puppetlabs/puppet-module-tool"
+ homepage => "https://github.com/puppetlabs/puppet-module-tool"
}
aws-iam-tools {
version => "1.3.0",
description => "The Command Line Interface (CLI) for the AWS Identity and Access Management (IAM) Service",
- homepage => " http://aws.amazon.com/developertools/AWS-Identity-and-Access-Management/4143"
+ homepage => "http://aws.amazon.com/developertools/AWS-Identity-and-Access-Management/4143"
}
aws-cfn-bootstrap {
version => "1.0-r6",
description => "Bootstrap scripts for AWS CloudFormation",
- homepage => " http://aws.amazon.com/developertools/4026240853893296"
+ homepage => "http://aws.amazon.com/developertools/4026240853893296"
}
amazon-ec2-init {
version => "20110331",
description => "Init script to setup Amazon EC2 instance parameters",
- homepage => " http://www.gentoo.org/"
+ homepage => "http://www.gentoo.org/"
}
}
@@ -90,7 +90,7 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
tpmmanager {
version => "0.8.1",
description => "TPM management software providing an easy to use graphical user interface",
- homepage => " http://projects.sirrix.com/trac/tpmmanager"
+ homepage => "http://projects.sirrix.com/trac/tpmmanager"
}
}
@@ -100,13 +100,13 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
komodo-edit-bin {
version => [ "6.1.3-r1", "7.0.0" ],
description => "Freeware advanced editor for dynamic and Web languages",
- homepage => " http://www.activestate.com/products/komodo_edit"
+ homepage => "http://www.activestate.com/products/komodo_edit"
}
geppetto {
version => "2.1.0",
description => "An integrated toolset for developing puppet modules and manifests",
- homepage => " http://cloudsmith.github.com/geppetto"
+ homepage => "http://cloudsmith.github.com/geppetto"
}
}
@@ -116,7 +116,7 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
lenovo-sl-laptop {
version => "9999",
description => "Linux kernel support for the Lenovo SL series ThinkPads",
- homepage => " http://github.com/tadzik/lenovo-sl-laptop"
+ homepage => "http://github.com/tadzik/lenovo-sl-laptop"
}
}
@@ -126,7 +126,7 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
tnote {
version => "0.2.1",
description => "A small note taking program for the terminal",
- homepage => " http://sourceforge.net/projects/tnote/"
+ homepage => "http://sourceforge.net/projects/tnote/"
}
}
@@ -136,13 +136,13 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
libreoffice-bin {
version => "3.4.3-r2",
description => "LibreOffice productivity suite.",
- homepage => " http://www.libreoffice.org"
+ homepage => "http://www.libreoffice.org"
}
libreoffice-l10n {
version => "3.4.3-r3",
description => "Translations for the Libreoffice suite.",
- homepage => " http://www.libreoffice.org"
+ homepage => "http://www.libreoffice.org"
}
}
@@ -152,7 +152,7 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
zsh-completions {
version => "9999",
description => "Additional completion definitions for Zsh",
- homepage => " https://github.com/zsh-users/zsh-completions"
+ homepage => "https://github.com/zsh-users/zsh-completions"
}
}
@@ -162,7 +162,7 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
Log-LogLite {
version => "0.82",
description => "The Log::LogLite class helps us create simple logs for our application",
- homepage => " "
+ homepage => ""
}
}
@@ -172,49 +172,49 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
fog {
version => "1.1.1",
description => "The Ruby cloud services library",
- homepage => " http://fog.io/"
+ homepage => "http://fog.io/"
}
excon {
version => "0.7.6",
description => "EXtended http(s) CONnections",
- homepage => " https://github.com/geemus/excon"
+ homepage => "https://github.com/geemus/excon"
}
zabbixapi {
version => "0.1.4-r1",
description => "Ruby module for work with Zabbix API",
- homepage => " http://github.com/verm666/RubyZabbixApi"
+ homepage => "http://github.com/verm666/RubyZabbixApi"
}
right_http_connection {
version => "1.3.0",
description => "RightScale's robust HTTP/S connection module",
- homepage => " http://rightscale.rubyforge.org/"
+ homepage => "http://rightscale.rubyforge.org/"
}
right_aws {
version => [ "2.1.0", "3.0.0" ],
description => "A robust, fast, and secure interface to Amazon EC2, EBS, S3, SQS, SDB, and CloudFront",
- homepage => " http://www.rightscale.com/"
+ homepage => "http://www.rightscale.com/"
}
formatador {
version => "0.2.1",
description => "STDOUT text formatting",
- homepage => " https://github.com/geemus/formatador"
+ homepage => "https://github.com/geemus/formatador"
}
zabbix {
version => "0.4.0",
description => "Send data to Zabbix from Ruby",
- homepage => " https://github.com/mhat/zabbix-rb"
+ homepage => "https://github.com/mhat/zabbix-rb"
}
aws-ses {
version => "0.4.3",
description => "Client library for Amazon's Simple Email Service's REST API",
- homepage => " https://github.com/drewblas/aws-ses"
+ homepage => "https://github.com/drewblas/aws-ses"
}
}
@@ -224,7 +224,7 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
kaption {
version => "0.1.1",
description => "A KDE utility similar to Jing or Skitch not yet as powerful as them",
- homepage => " http://opendesktop.org/content/show.php?content=139302"
+ homepage => "http://opendesktop.org/content/show.php?content=139302"
}
}
@@ -234,13 +234,13 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
yed {
version => "3.9",
description => "Powerful diagram editor that can be used to generate high-quality drawings of diagrams.",
- homepage => " http://www.yworks.com/en/products_yed_about.html"
+ homepage => "http://www.yworks.com/en/products_yed_about.html"
}
splash-themes-livecd {
version => "2010.0",
description => "Gentoo theme for gensplash consoles",
- homepage => " http://www.gentoo.org/"
+ homepage => "http://www.gentoo.org/"
}
}
@@ -250,13 +250,13 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
qutim {
version => "0.2.0-r4",
description => "New Qt4-based Instant Messenger (ICQ).",
- homepage => " http://www.qutim.org"
+ homepage => "http://www.qutim.org"
}
nagzilla {
version => "2.0",
description => "Jabber Relay Bot - for monitoring and any other sort of alert needs you have",
- homepage => " http://code.google.com/p/nagzilla/"
+ homepage => "http://code.google.com/p/nagzilla/"
}
}
@@ -266,13 +266,13 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
udpxy {
version => "1.0.21-r2",
description => "Daemon to relay multicast UDP traffic to client's TCP (HTTP) connection",
- homepage => " http://sourceforge.net/projects/udpxy"
+ homepage => "http://sourceforge.net/projects/udpxy"
}
rabbitmq-stomp-plugin {
version => [ "2.5.1", "2.6.1" ],
description => "RabbitMQ STOMP plugin.",
- homepage => " http://www.rabbitmq.com/plugins.html#rabbitmq-stomp"
+ homepage => "http://www.rabbitmq.com/plugins.html#rabbitmq-stomp"
}
}
@@ -282,7 +282,7 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
bbswitch {
version => "0.4.1-r1",
description => "Toggle the discrete graphics card",
- homepage => " https://github.com/Bumblebee-Project/bbswitch"
+ homepage => "https://github.com/Bumblebee-Project/bbswitch"
}
}
@@ -292,7 +292,7 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
aws-tools {
version => "0",
description => "Virtual for AWS tools",
- homepage => " "
+ homepage => ""
}
}
@@ -302,13 +302,13 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
nevernote {
version => "0.99",
description => "An open source Evernote clone",
- homepage => " http://nevernote.sourceforge.net/index.htm"
+ homepage => "http://nevernote.sourceforge.net/index.htm"
}
qomodoro {
version => "0.1-r1",
description => "Cross-platform pomodoro timer written in C++ using Qt4",
- homepage => " http://sourceforge.net/p/qomodoro/"
+ homepage => "http://sourceforge.net/p/qomodoro/"
}
}
@@ -318,13 +318,13 @@ overlay path now is in lowercase. You should re-add it to Layman or fix '.git/co
milky {
version => [ "2.0", "2.0_alpha2" ],
description => "Icon theme for KDE 4 designed by Banu Onal",
- homepage => " http://kde-look.org/content/show.php/Milky?content=133124"
+ homepage => "http://kde-look.org/content/show.php/Milky?content=133124"
}
qutim-kolobok {
version => "0.0.2",
description => "Kolobok smile pack for net-im/qutim",
- homepage => " http://www.qutim.org"
+ homepage => "http://www.qutim.org"
}
}
View
2 scripts/prepare_readme.rb
@@ -51,7 +51,7 @@ def dir_entries
readme.puts " version => \"#{package[:version].sort.join('", "')}\"" + ','
end
readme.puts " description => \"#{package[:description]}\"" + ','
- readme.puts " homepage => \" #{package[:homepage]}\""
+ readme.puts " homepage => \"#{package[:homepage]}\""
readme.puts " }"
end
readme.puts "\n }"
View
5 virtual/aws-tools/ChangeLog
@@ -2,7 +2,10 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
-*vitrual/aws-tools (06 Feb 2012)
+*vitrual/aws-tools (25 Feb 2012)
+
+ 25 Feb 2012; Scrill
+ ami and +api use flags
06 Feb 2012; Scrill
+aws-tools-0.ebuild:
View
6 virtual/aws-tools/Manifest
@@ -1,3 +1,3 @@
-EBUILD aws-tools-0.ebuild 513 RMD160 c2e5c0d0725480719221fc2fa48d9efcd1a1dbe7 SHA1 5754ee99a553b888039048bb57fef77f8d58314b SHA256 48a89bfa2f3a85eee268194ec88384a126f6595a5526eb7e0dfb13a113af4409
-MISC ChangeLog 207 RMD160 4e28adfc57c86fcf2dc483e581db0343aa769027 SHA1 a03c2929e485ff77ec5e5eace7e6ed8b024acbff SHA256 a76661cabf0ce4357a50a23e0b119ec0c3cc5b75141d9f0d953567a2783c6186
-MISC metadata.xml 698 RMD160 5022fd845d3844461fc59d9e57ebb8927c67b4ba SHA1 42cf74f9de50fcefe0dec794f7125974f66e40bc SHA256 dafd43124331915e06db4ce795a3fc6795794a5f16e10ff6c4500c026ee3fbd8
+EBUILD aws-tools-0.ebuild 602 RMD160 e40f62ccbcbc0521c9b3ded977026a76dec37a22 SHA1 d693be58ee302d248e7193a1ae464185b9b61e65 SHA256 3c3268829ff8a436f6ed94fe197c8bcac6ea8e372c43e142b48aad96bfa05d4d
+MISC ChangeLog 255 RMD160 e40298585f53222dbffa0ca0e1b2d63d1c0e2845 SHA1 97f4a9b336a005753f17d876c620ea1bef1ea825 SHA256 ba9b31cd8812811c92d29a14b894c69090797e9fbb38fb3464f0ce4c70170997
+MISC metadata.xml 814 RMD160 7aabcc3574af13ba4e43fedc1e7ec2133d82ffe8 SHA1 9dad628484994878dc0a1cb4718c0f77796fc99b SHA256 6086fe2d80df07d2bb50fa99863e9289829d186d361c6c1a04d67cd22ccc3a7d
View
8 virtual/aws-tools/aws-tools-0.ebuild
@@ -2,17 +2,21 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="2"
+
DESCRIPTION="Virtual for AWS tools"
HOMEPAGE=""
SRC_URI=""
LICENSE=""
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="as cfn cw elb iam rds sns"
+IUSE="ami +api as cfn cw elb iam rds sns"
DEPEND=""
-RDEPEND="as? ( app-admin/aws-as-tools )
+RDEPEND="ami? ( app-admin/ec2-ami-tools )
+ api? ( app-admin/ec2-api-tools )
+ as? ( app-admin/aws-as-tools )
cfn? ( app-admin/aws-cfn-tools )
cw? ( app-admin/aws-cw-tools )
elb? ( app-admin/aws-elb-tools )
View
2 virtual/aws-tools/metadata.xml
@@ -5,6 +5,8 @@
<email>sergey.zhuga@gmail.com</email>
</maintainer>
<use>
+ <flag name='ami'>Support for AWS EC2 AMI tools</flag>
+ <flag name='api'>Support for AWS EC2 API tools</flag>
<flag name='as'>Support for Auto Scaling tools</flag>
<flag name='cfn'>Support for CloudFormation tools</flag>
<flag name='cw'>Support for CloudWatch tools</flag>

0 comments on commit af78d27

Please sign in to comment.