Building Notational Velocity

scrod edited this page Sep 13, 2010 · 8 revisions

Platform Targets

Notational Velocity is built as a single multi-architecture PPC/i386/x86-64 executable and targets Mac OS X 10.4 through 10.6. On x86-64 the base SDK and deployment target are both 10.5, while the deployment target (minimum required OS version) on other architectures is 10.4.

Requirements

Building the project requires Xcode 3.1 or later. Hence, Mac OS X 10.5 or later is required. (On Snow Leopard, you must install Xcode 3.2 or later.)

For ensuring compatibility, the 10.4u SDK should be installed as well.

RBSplitView

For the moment, Notational Velocity’s main window uses Rainer Brockerhoff’s RBSplitView. Consequently, to modify MainMenu.nib, the RBSplitView Interface Builder palette is required.

On Leopard, because the latest version of this palette is incompatible with the Interface Builder of Xcode 3.1, you must install Xcode 2.5 and place version 1.1.4 of the palette in /Xcode2.5/Palettes/.

You can then use the version of Interface Builder in /Xcode2.5/Applications/ to open these errant .nibs.

On Snow Leopard you can use the latest version of Xcode (3.2) with the latest version of the RBSplitView palette (1.2). No other downloads are necessary.