`p` doesn't work #67

Open
masylum opened this Issue May 25, 2011 · 6 comments

4 participants

@masylum

I updated to the latest nerdtree version and p no longer works to visit the parent node.

@scrooloose
Owner

hey guys, its working here. What nerdtree options are you using?

@sergey-miryanov

Hi, I use vundle (if that matter) and in my .vimrc following options:

    Bundle 'git://github.com/scrooloose/nerdtree.git'

    let NERDTreeShowBookmarks=1
    let NERDTreeChDirMode=2
    let NERDTreeQuitOnOpen=1
    let NERDTreeShowHidden=1
    let NERDTreeKeepTreeInNewTab=0
    let NERDTreeMinimalUI=1 " Disables display of the 'Bookmarks' label and 'Press ? for help' text.
    let NERDTreeDirArrows=1 " Tells the NERD tree to use arrows instead of + ~ chars when displaying directories.
@scrooloose
Owner

Its working here with those options set.

What version of vim are you guys using?

@masylum

Macvim, and vim 7.3

@complex857

I'm pretty sure it's not related (this issue was opened back in 2011) but since it's an open one, i thought this might be good here too.

It seems to me that p is broken when i want to go up from a directory that's parent line is combined of multiple dirs. This is a new feature from this commit.

So if i have it like this

  ~ views/some_folder/
    + boxs/ <--- this is where my cursor is

Then p wont work, while if there's no such combined directory in the path then it works as before.
Clarification: "Won't work" as in the selected line jumps up to the combined directory but won't go to the parent of the combined one, so in the example, it would stuck on ~ views/some_folder/.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment