Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

fix a bug with highlighting and getmatches

Highlighting requires vim >= 7.1 with patch 40. It should be disabled
otherwise.

Fix a bug with the version check.

Closes #250.
  • Loading branch information...
commit 36db8f4b164a5f72e5f1b914521c284c82d0b407 1 parent aba5dd4
@scrooloose authored
Showing with 2 additions and 3 deletions.
  1. +2 −3 plugin/syntastic.vim
View
5 plugin/syntastic.vim
@@ -55,9 +55,8 @@ if !exists("g:syntastic_enable_highlighting")
endif
" highlighting requires getmatches introduced in 7.1.040
-if g:syntastic_enable_highlighting == 1 &&
- \ (v:version < 701 || v:version == 701 && has('patch040'))
- let g:syntastic_enable_highlighting = 1
+if v:version < 701 || (v:version == 701 && !has('patch040'))
+ let g:syntastic_enable_highlighting = 0
endif
if !exists("g:syntastic_echo_current_error")
Please sign in to comment.
Something went wrong with that request. Please try again.