New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Declare MIN_PERL_VERSION and require at least ExtUtils::MakeMaker 6.48 #26

Open
wants to merge 1 commit into
base: master
from

Conversation

Projects
None yet
3 participants
@jluis

jluis commented Apr 21, 2015

This is for the April cpan pull request chalenge.

I saw the to do list on the package and the isues but I prefered to address first the low hanbaging fruit of increasing the Kwalitee.

Fell free to request more work from me :)

Jluis

@chocolateboy

This comment has been minimized.

Show comment
Hide comment
@chocolateboy

chocolateboy Apr 23, 2015

Collaborator

Thanks for this!

Since metadata typically falls into the category of nice-to-have rather than must-have, I tend to favour a "work with what's available" approach rather than (possibly) forcing an ExtUtils::MakeMaker (EUMM) upgrade. The minimum perl version can still be enforced on systems with older EUMMs by a use VERSION statement.

See here for an example e.g.:

use 5.008;

my $EUMM_VERSION = eval($ExtUtils::MakeMaker::VERSION);

my $META_MERGE = {
    resources => {
        bugtracker => 'https://github.com/scrottie/autobox-Core/issues',
        repository => 'https://github.com/scrottie/autobox-Core',
    }
};

WriteMakefile(
    # ...
    ($EUMM_VERSION >= 6.48 ? (MIN_PERL_VERSION => '5.8.0') : ()),
    ($EUMM_VERSION >= 6.31 ? (LICENSE => 'perl') : ()),
    ($EUMM_VERSION >= 6.46 ? (META_MERGE => $META_MERGE) : ()),
    # ...
);
Collaborator

chocolateboy commented Apr 23, 2015

Thanks for this!

Since metadata typically falls into the category of nice-to-have rather than must-have, I tend to favour a "work with what's available" approach rather than (possibly) forcing an ExtUtils::MakeMaker (EUMM) upgrade. The minimum perl version can still be enforced on systems with older EUMMs by a use VERSION statement.

See here for an example e.g.:

use 5.008;

my $EUMM_VERSION = eval($ExtUtils::MakeMaker::VERSION);

my $META_MERGE = {
    resources => {
        bugtracker => 'https://github.com/scrottie/autobox-Core/issues',
        repository => 'https://github.com/scrottie/autobox-Core',
    }
};

WriteMakefile(
    # ...
    ($EUMM_VERSION >= 6.48 ? (MIN_PERL_VERSION => '5.8.0') : ()),
    ($EUMM_VERSION >= 6.31 ? (LICENSE => 'perl') : ()),
    ($EUMM_VERSION >= 6.46 ? (META_MERGE => $META_MERGE) : ()),
    # ...
);
@scrottie

This comment has been minimized.

Show comment
Hide comment
@scrottie

scrottie Apr 23, 2015

Owner

Hi Jluis,

Sorry I've been silent. I'm behind on stuff as usual.

Explicitly supporting older systems at the cost of requiring a MakeMaker upgrade doesn't really seem like the way to go.

Thank you for your offer of continued help! There are some tickets in https://github.com/scrottie/autobox-Core/issues and I think they're worthy of attention, but I'd be happy to try to confirm individual ones before you started any work on them.

Cheers,
-scott

Owner

scrottie commented Apr 23, 2015

Hi Jluis,

Sorry I've been silent. I'm behind on stuff as usual.

Explicitly supporting older systems at the cost of requiring a MakeMaker upgrade doesn't really seem like the way to go.

Thank you for your offer of continued help! There are some tickets in https://github.com/scrottie/autobox-Core/issues and I think they're worthy of attention, but I'd be happy to try to confirm individual ones before you started any work on them.

Cheers,
-scott

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment