Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

GRAPHICS: Fix no shader error on Raspberry PI #2610

Merged
merged 1 commit into from Nov 9, 2020

Conversation

@lmerckx
Copy link
Contributor

@lmerckx lmerckx commented Nov 7, 2020

On Raspberry PI, an error in OpenGLES shaders is not reported during the compilation step but during the link step.
See https://www.raspberrypi.org/forums/viewtopic.php?t=26205 for more information (last post).

This commit simply adds reporting of errors which occurred during the link step.

@lmerckx
Copy link
Contributor Author

@lmerckx lmerckx commented Nov 7, 2020

Useful to debug some shaders which are not compatible with Raspberry.

@aquadran aquadran merged commit 373f872 into scummvm:master Nov 9, 2020
2 checks passed
2 checks passed
continuous-integration/travis-ci/pr The Travis CI build passed
Details
deepcode-ci-bot Well done, no issues found!
Details
@lmerckx lmerckx deleted the lmerckx:graphics_shader_link branch Nov 11, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants
You can’t perform that action at this time.