Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

GROOVIE: check for USE_MAD for MP3 #3418

Merged
merged 1 commit into from Oct 13, 2021
Merged

Conversation

@mistydemeo
Copy link
Contributor

@mistydemeo mistydemeo commented Oct 13, 2021

The groovie engine is unconditionally trying to acess the Audio::makeMP3Stream method, which won't exist if ScummVM is being compiled without MAD. Other consumers use this #ifdef to determine if they should try to call it, so I've made the same change here.

The groovie engine is unconditionally trying to acess the
`Audio::makeMP3Stream` method, which won't exist if ScummVM is
being compiled without MAD. Other consumers use this `#ifdef` to
determine if they should try to call it, so I've made the same
change here.
@Die4Ever
Copy link
Member

@Die4Ever Die4Ever commented Oct 13, 2021

Interesting

Another option is to use #ifdef ENABLE_GROOVIE2 and make MAD be a requirement for the Groovie2 sub-engine in https://github.com/scummvm/scummvm/blob/master/engines/groovie/configure.engine

but maybe this way is better, especially because not all Groovie2 games use mp3s

@bluegr
Copy link
Member

@bluegr bluegr commented Oct 13, 2021

Thanks for your work!

This is definitely the right way to do this - MP3 related code should be enabled if libmad is compiled into ScummVM, and not if a subengine is enabled.

Merging

@bluegr bluegr merged commit 562c0f7 into scummvm:master Oct 13, 2021
8 checks passed
@mistydemeo mistydemeo deleted the groovie_USE_MAD branch Oct 13, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
3 participants