Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

IE 11 downloading .json file #300

Closed
memphisraynz opened this Issue Feb 23, 2015 · 6 comments

Comments

Projects
None yet
3 participants
@memphisraynz
Copy link

memphisraynz commented Feb 23, 2015

Trying to login under Internet Explorer 11 and the broswer tries to save the JSON response as an attachment.
The contents are simply {"status":"success","message":"Logging you in..."}

Cheers

@funkaoshi funkaoshi added deployment bug and removed deployment labels Feb 23, 2015

@hhaidar

This comment has been minimized.

Copy link
Member

hhaidar commented Feb 23, 2015

Working fine for me on Windows 7 with IE11.

Does the console show any errors?

@memphisraynz

This comment has been minimized.

Copy link
Author

memphisraynz commented Feb 23, 2015

Nothing, the only message I receive is the same message I've been getting from the start
express deprecated req.host: Use req.hostname instead node_modules/express.oi/lib/index.js:72:46

@hhaidar

This comment has been minimized.

Copy link
Member

hhaidar commented Feb 23, 2015

I mean the IE11 console: https://msdn.microsoft.com/en-us/library/ie/dn255006%28v=vs.85%29.aspx

This issue happens when javascript breaks in the login page.

@memphisraynz

This comment has been minimized.

Copy link
Author

memphisraynz commented Feb 23, 2015

After opening console I found that IE was running Intranet sites in compatibility mode. Because this is running on the local network it considers it Intranet.

@hhaidar

This comment has been minimized.

Copy link
Member

hhaidar commented Feb 23, 2015

@memphisraynz try pulling the latest from master and restart your server. We should be sending an X-UA-Compatible header now.

@memphisraynz

This comment has been minimized.

Copy link
Author

memphisraynz commented Feb 23, 2015

Thanks,
One I set IE to not use compatibility mode it works perfectly.
Cheers

@hhaidar hhaidar closed this Feb 23, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.