Skip to content

Installation

Houssam Haidar edited this page Sep 1, 2016 · 12 revisions

Prerequisites

Node.js (0.11+)

See the official Node.js installation documentation.

MongoDB (2.6+)

See the official MongoDB installation documentation.

Python (2.7.x)

Required by node-gyp.

Installation

Clone the Let's Chat repository, and install dependencies.

git clone https://github.com/sdelements/lets-chat.git
cd lets-chat
npm install

(Optional) For custom settings, copy and edit settings.yml.sample:

cp settings.yml.sample settings.yml

Important Security Notes

See https://github.com/sdelements/lets-chat/wiki/Authentication#local-authentication for details on changing the default authentication settings. The default settings may be too insecure for your environment.

Upgrading

Backup both your installation, and the database.

git pull
npm run-script migrate

Running the application

Ensure that MongoDB is running, and start the application.

npm start

Party time: http://localhost:5000

You can’t perform that action at this time.