Node installation on the Raspberry Pi Zero
Switch branches/tags
Nothing to show
Clone or download
Permalink
Failed to load latest commit information.
README.md Update README.md Mar 19, 2018
install-node-v.last.sh Using a simples way to get the architecture Apr 21, 2017
install-node-v.lts.sh Update install-node-v.lts.sh Apr 21, 2017
install-node-v4.0.0.sh adding more versions Dec 12, 2016
install-node-v4.4.1.sh adding more versions Dec 12, 2016
install-node-v4.7.0.sh adding more versions Dec 12, 2016
install-node-v4.8.7.sh Create install-node-v4.8.7.sh Mar 19, 2018
install-node-v5.0.0.sh adding more versions Dec 12, 2016
install-node-v5.12.0.sh adding more versions Dec 12, 2016
install-node-v6.0.0.sh adding more versions Dec 12, 2016
install-node-v6.11.3.sh Create install-node-v6.11.3.sh Sep 12, 2017
install-node-v6.13.1.sh Create install-node-v6.13.1.sh Mar 19, 2018
install-node-v6.4.0.sh adding more versions Dec 12, 2016
install-node-v6.9.1.sh adding more versions Dec 12, 2016
install-node-v7.2.1.sh adding more versions Dec 12, 2016
install-node-v7.7.1.sh Adding install-node-v7.7.1.sh Mar 3, 2017
install-node-v8.10.0.sh Create install-node-v8.10.0.sh Mar 18, 2018
install-node-v8.4.0.sh Create install-node-v8.4.0.sh Sep 12, 2017
install-node-v8.5.0.sh Create install-node-v8.5.0.sh Sep 27, 2017
install-node-v8.6.0.sh Add support for Node 8.6.0 version Oct 19, 2017
install-node-v8.7.0.sh Add support for Node 8.7.0 version Oct 15, 2017
install-node-v8.8.0.sh Update for Node 8.8.0 and 8.8.1 Oct 26, 2017
install-node-v8.8.1.sh Update for Node 8.8.0 and 8.8.1 Oct 26, 2017
install-node-v8.9.0.sh Support for 8.9.0 - new LTS Oct 31, 2017
install-node-v9.0.0.sh Create install-node-v9.0.0.sh Mar 18, 2018
install-node-v9.5.0.sh Create install-node-v9.5.0.sh Mar 18, 2018
install-node-v9.8.0.sh Create install-node-v9.8.0.sh Mar 18, 2018
pizero.png Add files via upload Dec 28, 2016

README.md

Node Pi Zero

node-pi-zero

Use the commands below to install node in the Raspberry Pi Zero.

They are re-runnable so you can upgrade or downgrade just by running the command for each version.

v4.0.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v4.0.0.sh | bash

v4.4.1

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v4.4.1.sh | bash

v4.7.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v4.7.0.sh | bash

v4.8.7

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v4.8.7.sh | bash

v5.0.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v5.0.0.sh | bash

v5.12.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v5.12.0.sh | bash

v6.0.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v6.0.0.sh | bash

v6.4.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v6.4.0.sh | bash

v6.9.1

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v6.9.1.sh | bash

v6.11.3

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v6.11.3.sh | bash

v6.13.1

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v6.13.1.sh | bash

v7.2.1

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v7.2.1.sh | bash

v7.7.1

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v7.7.1.sh | bash

v8.4.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v8.4.0.sh | bash

v8.5.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v8.5.0.sh | bash

v8.6.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v8.6.0.sh | bash

v8.7.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v8.7.0.sh | bash

v8.8.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v8.8.0.sh | bash

v8.8.1

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v8.8.1.sh | bash

v8.9.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v8.9.0.sh | bash

v8.10.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v8.10.0.sh | bash

v9.0.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v9.0.0.sh | bash

v9.5.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v9.5.0.sh | bash

v9.8.0

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v9.8.0.sh | bash

v.lts

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v.lts.sh | bash

v.last

$ wget -O - https://raw.githubusercontent.com/sdesalas/node-pi-zero/master/install-node-v.last.sh | bash

Looking for a specific version? The following fork which has every version listed.

When finished just check the node and npm versions.

$ node -v
$ npm -v

Using global npm modules? (ie mocha, eslint, etc)

Add the following to the end of your ~/.profile file:

# Add support for node CLI tools
export PATH=$PATH:/opt/nodejs/bin

And remember, friends dont let friends pipe to sh.