sdk list [candidate] doesn't list all versions #465

Open
KevinGreene opened this Issue Sep 2, 2016 · 3 comments

Projects

None yet

3 participants

@KevinGreene
KevinGreene commented Sep 2, 2016 edited

Currently, sdk list grails produces the following output for me:

================================================================================
Available Grails Versions
================================================================================
     3.2.0.RC1            3.1.0.RC1            3.0.15               2.4.5
     3.2.0.M2             3.1.0.M3             3.0.14               2.4.4
     3.2.0.M1             3.1.0.M2             3.0.13               2.4.3
 > * 3.1.9                3.1.0.M1             3.0.12               2.4.2
     3.1.8                3.1.0                3.0.11               2.4.1
   * 3.1.7                3.0.9                3.0.10               2.4.0
     3.1.6                3.0.8                3.0.1                2.3.9
     3.1.5                3.0.7                3.0.0                2.3.8
     3.1.4                3.0.6                2.5.5.BUILD-SNA    * 2.3.7
     3.1.3                3.0.5                2.5.5                2.3.6
     3.1.2                3.0.4                2.5.4                2.3.5
     3.1.11               3.0.3                2.5.3                2.3.4
     3.1.10               3.0.2                2.5.2                2.3.3
     3.1.1                3.0.17               2.5.1                2.3.2
     3.1.0.RC2            3.0.16               2.5.0                2.3.11

================================================================================

However, I need to use grails 2.2.x. After finding the latest version of 2.2.x from the grails website, I was able to install it with sdk install grails 2.2.5.

@marc0der
Member
marc0der commented Sep 2, 2016

I've opened up some space in the list view by removing obsolete versions for now. I'll keep this ticket open to make some changes to the list view allowing for more versions.

@eprozium

Also the order of the candidates is alphanumeric not semver :(.

@marc0der
Member

Yes, that's a know issue and will be addressed in the rewrite of the candidates service.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment