Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Switch backend from ActiveSupport::Notifications to AS::Notifications.

  • Loading branch information...
commit 509df721ebd9df1725f6590ae568ffdfb0c6b8d7 1 parent f1522af
@bernd bernd authored
View
4 lib/webmachine/events.rb
@@ -1,5 +1,5 @@
require 'securerandom' # For AS::Notifications
-require 'active_support/notifications'
+require 'as/notifications'
require 'webmachine/events/instrumented_event'
module Webmachine
@@ -28,6 +28,6 @@ def unsubscribe(subscriber)
end
end
- self.backend = ActiveSupport::Notifications
+ self.backend = AS::Notifications
end
end
View
4 lib/webmachine/events/instrumented_event.rb
@@ -1,11 +1,11 @@
require 'delegate'
-require 'active_support/notifications/instrumenter'
+require 'as/notifications/instrumenter'
module Webmachine
module Events
class InstrumentedEvent < SimpleDelegator
def initialize(*args)
- super(ActiveSupport::Notifications::Event.new(*args))
+ super(AS::Notifications::Event.new(*args))
end
end
end
View
2  webmachine.gemspec
@@ -16,7 +16,7 @@ Gem::Specification.new do |gem|
gem.add_runtime_dependency(%q<i18n>, [">= 0.4.0"])
gem.add_runtime_dependency(%q<multi_json>)
- gem.add_runtime_dependency(%q<activesupport>, ["~> 3.2.0"])
+ gem.add_runtime_dependency(%q<as-notifications>, ["~> 0.2"])
gem.add_development_dependency(%q<rspec>, ["~> 2.12.0"])
gem.add_development_dependency(%q<yard>, ["~> 0.7.3"])
gem.add_development_dependency(%q<rake>)
Please sign in to comment.
Something went wrong with that request. Please try again.