Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Unbreak CI for JRuby 1.8 #75

Merged
merged 1 commit into from

4 participants

@bernd
Collaborator

This should fix the Travis jruby-18mode which has been broken since the pull request #51.

It's not really nice but I don't see any other way. Okay to merge?

@bernd bernd Unbreak CI for JRuby 1.8.
Bundler can't differentiate between JRuby 1.8 and 1.9 platforms in the
Gemfile. Only include the reel gem if we are on >=1.9 so the Travis
jruby-18mode can work again.
6f153d1
@lgierth
Collaborator

I had to guard the Hatetepe adapter against running in 1.8 mode, too. The specs just get skipped unless RUBY_VERSION >= "1.9": https://github.com/seancribbs/webmachine-ruby/blob/master/spec/webmachine/adapters/hatetepe_spec.rb

No strong opinion on which approach is better, though.

@seancribbs
Owner

@lgierth @bernd Yes, I prefer the skip-specs version, but I understand Reel won't even install properly, so it makes sense to handle that in the Gemfile. If this passes, please merge.

@bernd
Collaborator

Only jruby-19mode fails due to a problem with the nio4r gem. (see bundler/bundler#2158) The rest is fine now.

@bernd bernd merged commit e5f483d into from
@seancribbs
Owner

Thanks @bernd!

@tarcieri
Collaborator

Note that the nio4r failures should be fixed now. They're due to a bundler-api bug o_O

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Nov 13, 2012
  1. @bernd

    Unbreak CI for JRuby 1.8.

    bernd authored
    Bundler can't differentiate between JRuby 1.8 and 1.9 platforms in the
    Gemfile. Only include the reel gem if we are on >=1.9 so the Travis
    jruby-18mode can work again.
This page is out of date. Refresh to see the latest.
Showing with 3 additions and 1 deletion.
  1. +3 −1 Gemfile
View
4 Gemfile
@@ -8,7 +8,9 @@ gem 'bundler'
group :webservers do
gem 'mongrel', '~> 1.2.beta', :platform => [:mri, :rbx]
- gem 'reel', '>= 0.1.0', :platform => [:ruby_19, :jruby]
+ if RUBY_VERSION >= '1.9'
+ gem 'reel', '>= 0.1.0', :platform => [:ruby_19, :jruby]
+ end
gem 'hatetepe', '~> 0.5'
end
Something went wrong with that request. Please try again.