Permalink
Browse files

Add optional support for fastcgi.

  • Loading branch information...
1 parent b1cb340 commit d560b413412928d128e44d530fbf8d73f7948ca3 @seanlynch committed Jun 14, 2012
Showing with 6 additions and 0 deletions.
  1. +6 −0 Library/Formula/mapserver.rb
@@ -11,9 +11,11 @@ class Mapserver < Formula
depends_on 'geos' if ARGV.include? '--with-geos'
depends_on 'postgresql' if ARGV.include? '--with-postgresql' and not MacOS.lion?
+ depends_on 'fcgi' if ARGV.include? '--with-fastcgi'
def options
[
+ ["--with-fastcgi", "Build with fastcgi support"],
["--with-geos", "Build support for GEOS spatial operations"],
["--with-php", "Build PHP MapScript module"],
["--with-postgresql", "Build support for PostgreSQL as a data source"]
@@ -40,6 +42,10 @@ def configure_args
end
end
+ if ARGV.include? '--with-fastcgi'
+ args.push "--with-fastcgi=#{HOMEBREW_PREFIX}"
+ end
+
args
end

0 comments on commit d560b41

Please sign in to comment.