Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Cleanup gemspec/gemfile

  • Loading branch information...
commit b9a1d03de0a234c4bdc8ff8039c9e8860aa102b2 1 parent 4225566
@erwaller erwaller authored
Showing with 33 additions and 48 deletions.
  1. +1 −16 Gemfile
  2. +7 −6 Rakefile
  3. +25 −26 soulmate.gemspec
View
17 Gemfile
@@ -1,18 +1,3 @@
source "http://rubygems.org"
-# Add dependencies required to use your gem here.
-# Example:
-# gem "activesupport", ">= 2.3.5"
-# Add dependencies to develop your gem here.
-# Include everything needed to run rake, tests, features, etc.
-group :development do
- gem "shoulda", ">= 0"
- gem "bundler", "~> 1.0.0"
- gem "jeweler", "~> 1.5.2"
-end
-
-gem 'redis', "~> 2.1.1"
-gem 'multi_json', "~> 1"
-gem 'rack-contrib'
-gem 'vegas', "~> 0.1"
-gem 'sinatra', "~> 1.3"
+gemspec
View
13 Rakefile
@@ -22,12 +22,13 @@ Jeweler::Tasks.new do |gem|
gem.email = "eric@seatgeek.com"
gem.homepage = "http://github.com/seatgeek/soulmate"
gem.authors = ["Eric Waller"]
- # The versions specified here are pretty arbitrary right now...
- gem.add_runtime_dependency 'redis', '>= 2.0'
- gem.add_runtime_dependency 'vegas', '>= 0.1.0'
- gem.add_runtime_dependency 'sinatra', '>= 1.0'
- gem.add_runtime_dependency 'json', '~> 1.4.6'
- # gem.add_development_dependency 'rspec', '> 1.2.3'
+ gem.add_development_dependency "shoulda", ">= 0"
+ gem.add_development_dependency "bundler", "~> 1.0"
+ gem.add_development_dependency "jeweler", "~> 1.5"
+ gem.add_runtime_dependency 'redis', '>= 2.0'
+ gem.add_runtime_dependency 'vegas', '>= 0.1.0'
+ gem.add_runtime_dependency 'sinatra', '>= 1.0'
+ gem.add_runtime_dependency 'multi_json', '>= 1.0'
end
Jeweler::RubygemsDotOrgTasks.new
View
51 soulmate.gemspec
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Eric Waller"]
- s.date = %q{2012-01-05}
+ s.date = %q{2012-03-21}
s.description = %q{Soulmate is a tool to help solve the common problem of developing a fast autocomplete feature. It uses Redis's sorted sets to build an index of partial words and corresponding top matches, and provides a simple sinatra app to query them. Soulmate finishes your sentences.}
s.email = %q{eric@seatgeek.com}
s.executables = ["soulmate", "soulmate-web"]
@@ -20,7 +20,6 @@ Gem::Specification.new do |s|
s.files = [
".document",
"Gemfile",
- "Gemfile.lock",
"LICENSE.txt",
"README.markdown",
"Rakefile",
@@ -55,48 +54,48 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<redis>, ["~> 2.1.1"])
- s.add_runtime_dependency(%q<multi_json>, ["~> 1.0.3"])
- s.add_runtime_dependency(%q<rack-contrib>, [">= 0"])
- s.add_runtime_dependency(%q<vegas>, ["~> 0.1.8"])
- s.add_runtime_dependency(%q<sinatra>, ["~> 1.2.3"])
+ s.add_runtime_dependency(%q<soulmate>, [">= 0"])
s.add_development_dependency(%q<shoulda>, [">= 0"])
- s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.5.2"])
s.add_development_dependency(%q<rcov>, [">= 0"])
+ s.add_development_dependency(%q<shoulda>, [">= 0"])
+ s.add_development_dependency(%q<bundler>, ["~> 1.0"])
+ s.add_development_dependency(%q<jeweler>, ["~> 1.5"])
+ s.add_development_dependency(%q<shoulda>, [">= 0"])
+ s.add_development_dependency(%q<bundler>, ["~> 1.0"])
+ s.add_development_dependency(%q<jeweler>, ["~> 1.5"])
s.add_runtime_dependency(%q<redis>, [">= 2.0"])
s.add_runtime_dependency(%q<vegas>, [">= 0.1.0"])
s.add_runtime_dependency(%q<sinatra>, [">= 1.0"])
- s.add_runtime_dependency(%q<json>, [">= 1.4.6"])
+ s.add_runtime_dependency(%q<multi_json>, [">= 1.0"])
else
- s.add_dependency(%q<redis>, ["~> 2.1.1"])
- s.add_dependency(%q<multi_json>, ["~> 1.0.3"])
- s.add_dependency(%q<rack-contrib>, [">= 0"])
- s.add_dependency(%q<vegas>, ["~> 0.1.8"])
- s.add_dependency(%q<sinatra>, ["~> 1.2.3"])
+ s.add_dependency(%q<soulmate>, [">= 0"])
s.add_dependency(%q<shoulda>, [">= 0"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
s.add_dependency(%q<rcov>, [">= 0"])
+ s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<bundler>, ["~> 1.0"])
+ s.add_dependency(%q<jeweler>, ["~> 1.5"])
+ s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<bundler>, ["~> 1.0"])
+ s.add_dependency(%q<jeweler>, ["~> 1.5"])
s.add_dependency(%q<redis>, [">= 2.0"])
s.add_dependency(%q<vegas>, [">= 0.1.0"])
s.add_dependency(%q<sinatra>, [">= 1.0"])
- s.add_dependency(%q<json>, [">= 1.4.6"])
+ s.add_dependency(%q<multi_json>, [">= 1.0"])
end
else
- s.add_dependency(%q<redis>, ["~> 2.1.1"])
- s.add_dependency(%q<multi_json>, ["~> 1.0.3"])
- s.add_dependency(%q<rack-contrib>, [">= 0"])
- s.add_dependency(%q<vegas>, ["~> 0.1.8"])
- s.add_dependency(%q<sinatra>, ["~> 1.2.3"])
+ s.add_dependency(%q<soulmate>, [">= 0"])
s.add_dependency(%q<shoulda>, [">= 0"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
s.add_dependency(%q<rcov>, [">= 0"])
+ s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<bundler>, ["~> 1.0"])
+ s.add_dependency(%q<jeweler>, ["~> 1.5"])
+ s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<bundler>, ["~> 1.0"])
+ s.add_dependency(%q<jeweler>, ["~> 1.5"])
s.add_dependency(%q<redis>, [">= 2.0"])
s.add_dependency(%q<vegas>, [">= 0.1.0"])
s.add_dependency(%q<sinatra>, [">= 1.0"])
- s.add_dependency(%q<json>, [">= 1.4.6"])
+ s.add_dependency(%q<multi_json>, [">= 1.0"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.