Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

fix ruby2ruby dependency, later versions break heckle #2

Closed
wants to merge 1 commit into from

3 participants

@mockdeep

Any version of ruby2ruby later than 1.2.2 causes a 'translate' error in heckle.

@moonglum

The dependency must be fixed. See the difference between 1.2.2 and 1.3.1 in this gist

@phiggins
Owner

This should be fixed in master or on my ruby_parser branch, and will be available in a forthcoming heckle 2.0 release.

@phiggins phiggins closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Nov 23, 2011
  1. @mockdeep
This page is out of date. Refresh to see the latest.
Showing with 8 additions and 2 deletions.
  1. +6 −0 History.txt
  2. +1 −1  README.txt
  3. +1 −1  Rakefile
View
6 History.txt
@@ -1,3 +1,9 @@
+=== 1.4.4 / 2011-11-23
+
+* 1 bug fix:
+
+ * fixed Ruby2Ruby dependency and reference in README
+
=== 1.4.3 / 2009-06-23
* 2 minor enhancements:
View
2  README.txt
@@ -22,7 +22,7 @@ It's like hiring a white-hat hacker to try to break into your server and making
== REQUIREMENTS:
-* ruby2ruby 1.1.2 or greater
+* ruby2ruby 1.2.2
* ParseTree 1.6.1 or greater
== INSTALL:
View
2  Rakefile
@@ -22,7 +22,7 @@ Hoe.spec 'heckle' do
clean_globs << File.expand_path("~/.ruby_inline")
extra_deps << ['ParseTree', '>= 2.0.0']
- extra_deps << ['ruby2ruby', '>= 1.1.6']
+ extra_deps << ['ruby2ruby', '1.2.2']
extra_deps << ['ZenTest', '>= 3.5.2']
multiruby_skip << "1.9"
end
Something went wrong with that request. Please try again.