Browse files

+ Set required rubygems version to be >= 1.8 and < 2.1. (sanemat)

[git-p4: depot-paths = "//src/ZenTest/dev/": change = 8073]
  • Loading branch information...
1 parent 23539ca commit 99c4a39041c3431eae3ad838b7e663933b2d0c2e @zenspider zenspider committed Dec 18, 2012
Showing with 1 addition and 1 deletion.
  1. +1 −1 Rakefile
View
2 Rakefile
@@ -13,7 +13,7 @@ Hoe.spec "ZenTest" do
developer 'Ryan Davis', 'ryand-ruby@zenspider.com'
developer 'Eric Hodel', 'drbrain@segment7.net'
- require_rubygems_version "~> 1.8"
+ require_rubygems_version [">= 1.8", "< 2.1"]
end
desc "run autotest on itself"

2 comments on commit 99c4a39

@noahgibbs

Huh. You guys are setting this up correctly, with an array. Something on my end is converting it to a joined string, causing lots of ugly errors of the form:

Installing yard (0.8.3) Invalid gemspec in [/home/role-c3/.rvm/gems/ruby-1.9.2-p290@nodule/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

I've tried the obvious tricks (rvm gemset empty, then gem update --system, then update bundler, then reinstall) without luck. I'm leaving this comment here in case somebody else gets here with this problem. I'm told that obvious tricks works fine for most people, and it's worth documenting that it seems not to be ZenTest's fault.

@noahgibbs

Oh, there's an open issue as well: #28

Please sign in to comment.