Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Bad gemspec in 4.9.0 #32

Closed
epinault opened this Issue · 5 comments

2 participants

@epinault

% bundle exec rake app:start
Invalid gemspec in [/home/emmanuel/.gem/ruby/1.9.3/specifications/ZenTest-4.9.0.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]
Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.9.0.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]
Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.9.0.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]
Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.9.0.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

@zenspider
Owner

Please get in the habit of searching the closed issues.

Dupe of #29, #30, & #31

@zenspider zenspider closed this
@epinault

I did. All of them are Ruby 1.8 issues.

I am using Ruby 1.9.3- 327, Ubuntu 10.04, no rvm or rbenv. Just plain ruby locally compiled

The gem is not installed as a gem but only via Bundler and it comes as dependencies from RubyInline (and wished I did not have that have that Gem since I don t use ZenTest). I reported it as a good habit rather than ignoring the issue.... Sorry I forgot to provide the details above those it was visible in my post the main ruby version I use and the fact that i use it via bundler...

Still not solve my issue

@zenspider
Owner

No. They're not 1.8 issues. They're rubygems issues. Yes, you do have it installed as a gem bacause that's what bundler does: resolve gem dependencies and install gems. The solution described in #29 will solve your problems.

@epinault

but I have it installed in my local bundle.

I did bundle install --local --path vendor. and all the gem are in vendor cache. The install is fully working but when I exec it complains still.... That works for other gems usually and I don t need to install them locally as long as I use bundle exec . what am I missing?

@epinault

here is my locally install gem

gem list

*** LOCAL GEMS ***

bigdecimal (1.1.0)
bundler (1.2.3)
io-console (0.3)
json (1.5.4)
minitest (2.5.1)
rake (0.9.2.2)
rdoc (3.9.4)

and here os what I see when I do bundle install --path vendor --local

 bundle install --local --path vendor
Installing rake (10.0.3) 
Installing ZenTest (4.8.4) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing RubyInline (3.9.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing sexp_processor (3.2.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ParseTree (3.0.9) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing i18n (0.6.1) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing multi_json (1.6.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing activesupport (3.2.12) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing builder (3.0.4) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing activemodel (3.2.12) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing arel (3.0.2) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing tzinfo (0.3.35) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing activerecord (3.2.12) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing adapter_extensions (1.0.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing fastercsv (1.5.5) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing activewarehouse-etl (1.0.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing addressable (2.2.8) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing arrayfields (4.7.4) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing awesome_print (1.1.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing bcrypt-ruby (2.1.4) with native extensions Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing data_objects (0.10.9) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing dm-core (1.1.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing dm-aggregates (1.1.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing dm-do-adapter (1.1.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing dm-migrations (1.1.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing do_mysql (0.10.9) with native extensions Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing dm-mysql-adapter (1.1.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing json (1.4.6) with native extensions Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing dm-serializer (1.1.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing randexp (0.1.7) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing dm-sweatshop (1.1.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing dm-timestamps (1.1.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing dm-transactions (1.1.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing stringex (1.2.2) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing uuidtools (2.1.2) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing dm-types (1.1.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing dm-validations (1.1.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing fattr (2.2.1) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ffi (1.0.11) with native extensions Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ffi-icu (0.0.9) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing foreigner (1.3.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing google_visualr (2.1.6) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing haml (3.1.8) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing has-bit-field (1.0.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing mysql2 (0.3.11) with native extensions Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing net-ssh (2.6.5) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing net-scp (1.1.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing parallel-forkmanager (1.5.1) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing pg (0.14.1) with native extensions Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing postgres (0.8.1) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing rack (1.5.1) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing rack-protection (1.3.2) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing shotgun (0.9) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing simple_enum (1.4.1) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing tilt (1.3.3) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing sinatra (1.3.4) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ts_fast_yaml (0.1.5) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ts_right_http_connection (1.3.0) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ts_right_aws (2.0.11) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ts_cloud (0.1.79) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ts_configuration (0.1.2) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ts_common_config (0.1.33) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ts_core_ext (0.1.9) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ts_core (0.1.91) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ts_country_codes (0.1.3) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ts_sdbtools (0.5.7) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ts_dm-adapter-simpledb (1.105.15) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ts_resume (0.1.41) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Installing ts_state_codes (0.1.4) Invalid gemspec in [/home/emmanuel/talemetry/talemetry_warehouse/vendor/ruby/1.9.1/specifications/ZenTest-4.8.4.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

Using bundler (1.2.3) 
Updating files in vendor/cache
Your bundle is complete! It was installed into ./vendor
Post-install message from postgres:
---------------------------------------------------------------------------

This is an old, deprecated version of the Ruby PostgreSQL driver that hasn't
been maintained or supported since early 2008.

You should install/require 'pg' instead.

If you need the 'postgres' gem for legacy code that can't be converted, you can
still install it using an explicit version, like so:

  gem install postgres -v '0.7.9.2008.01.28'
  gem uninstall postgres -v '>0.7.9.2008.01.28'

If you have any questions, the nice folks in the Google group can help:

  http://goo.gl/OjOPP / ruby-pg@googlegroups.com
@epinault epinault referenced this issue
Closed

Question #33

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.