Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Invalid Gemspec generated with Zentest 4.9.0 #38

Closed
vishnun opened this Issue · 4 comments

4 participants

@vishnun

Invalid gemspec in [../.rvm/gems/ruby-1.9.3-p194/specifications/ZenTest-4.9.0.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]

The correct requirement seems to be ["< 2.1", ">= 1.8"]

The double quotes are missing.

I am using Ruby-1.9.3 just incase you need to know that.

@zenspider
Owner

The bug is in rubygems. Please update and reinstall zentest.

@zenspider zenspider closed this
@Hakben

I launch the command "gem install ZenTest" again just now from my Terminal. I still have this error message: Invalid gemspec in [../.rvm/gems/ruby-1.9.3-p194/specifications/ZenTest-4.9.0.gemspec]: Illformed requirement ["< 2.1, >= 1.8"]
Am i suppose to do something else?

@vishnun
@alexkwolfe alexkwolfe referenced this issue in seattlerb/rubyinline
Closed

ZenTest #33

@alexkwolfe

For those that are still dealing with this problem, you can lock ZenTest at version 4.3 to avoid it:

gem 'ZenTest', '= 4.3', require: false

Skipping require: false will load the full ZenTest gem which will set $TESTING = true. This causes problems in other libraries that switch on this global variable.

I ran into this exact problem with Resque.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.