Support for all rubygems versions #13

Closed
wants to merge 1 commit into
from

Projects

None yet

3 participants

@chaffeqa

Added regression support for rubygems <1.8.

Removed rubygems version require from hoe.

Added rdoc and minitest development dependencies to hoe

Note: Its tough to write tests for... but I simply made another rvm gemset on ruby 1.8.7, rubygems version: 1.4.2 and the tests all passed. (had to install rdoc and minitest gems, hence the development dependencies)

Perhaps those development dependencies need to be runtime?

@chaffeqa chaffeqa Added regression support for rubygems <1.8. Removed rubygems version …
…require from hoe. added rdoc and minitest development dependecies to hoe
172c6c6
@zenspider zenspider was assigned Nov 19, 2011
@gdelfino
gdelfino commented Jun 5, 2012

+1

@zenspider
Member

Added regression support for rubygems <1.8.
Removed rubygems version require from hoe.

No case has been made as to why I'd want to support more complex code. Instead, I clarified in the readme that rubygems 1.8+ is required per @agrimm's issue #18.

Added rdoc and minitest development dependencies to hoe

The dependencies are already there by virtue of hoe plugins:

  s.add_development_dependency(%q<minitest>, [">= 2.0.2"])
  s.add_development_dependency(%q<hoe>, [">= 2.9.1"])
@zenspider zenspider closed this Jun 7, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment