Release Announcement for PHPUnit 5.1.0

Sebastian Bergmann edited this page Jan 29, 2016 · 6 revisions

The PHPUnit development team announces the immediate availability of PHPUnit 5.1.0. This release adds new features and fixes bugs. A detailed list of changes is available here.

New Features

  • Added support for the --CLEAN-- and --EXPECTREGEX-- sections for PHPT test cases

Changes

  • Warnings such as No tests found in class "Test" are now properly implemented

Obtaining PHPUnit 5.1

We distribute a PHP Archive (PHAR) that contains everything you need in order to use PHPUnit. Simply download it from here, make it executable, and put it into your $PATH, for instance.

Alternatively, you may use Composer to download and install PHPUnit as well as its dependencies.

Requirements

PHPUnit 5.1 requires PHP 5.6; using the latest version of PHP is highly recommended. The documentation has a detailed list of the PHP extensions that are required to use PHPUnit.

Looking Ahead

The goal of our release process is to deliver new features into the hands of our users every two months. The following releases are currently in development:

  • PHPUnit 5.2 is the current beta release series of PHPUnit. It will become stable on February 4, 2016.
  • PHPUnit 5.3 is the current alpha release series of PHPUnit. It will become stable on April 1, 2016.

PHPUnit 6

PHPUnit 6, which is scheduled for August 5, 2016 February 3, 2017, will no longer support PHP 5. As PHPUnit follows Semantic Versioning the major version number must be incremented when the minimum required version of PHP is increased.

Support for PHPUnit 5

Following our release process, PHPUnit 5 will receive bug fixes until August 5, 2017 February 3, 2017.