Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can not install because using phpunit 7 #155

Closed
BonBonSlick opened this issue Jul 25, 2018 · 4 comments
Closed

Can not install because using phpunit 7 #155

BonBonSlick opened this issue Jul 25, 2018 · 4 comments
Assignees

Comments

@BonBonSlick
Copy link

Problem 1
    - Conclusion: don't install phpbu/phpbu 5.1.1
    - Conclusion: remove phpunit/php-timer 2.0.0
    - Installation request for phpbu/phpbu ^5.1 -> satisfiable by phpbu/phpbu[5.1.0, 5.1.1].
    - Conclusion: don't install phpunit/php-timer 2.0.0
    - phpbu/phpbu 5.1.0 requires phpunit/php-timer ~1.0 -> satisfiable by phpunit/php-timer[1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.0.9].
    - Can only install one of: phpunit/php-timer[1.0.3, 2.0.0].
    - Can only install one of: phpunit/php-timer[1.0.4, 2.0.0].
    - Can only install one of: phpunit/php-timer[1.0.5, 2.0.0].
    - Can only install one of: phpunit/php-timer[1.0.6, 2.0.0].
    - Can only install one of: phpunit/php-timer[1.0.7, 2.0.0].
    - Can only install one of: phpunit/php-timer[1.0.8, 2.0.0].
    - Can only install one of: phpunit/php-timer[1.0.9, 2.0.0].
    - Installation request for phpunit/php-timer (locked at 2.0.0) -> satisfiable by phpunit/php-timer[2.0.0].

We may install lower version of php-timer, but php unit will not work.

@sebastianfeldmann
Copy link
Owner

I'll have a look if I can safely use 1 or 2

@sebastianfeldmann
Copy link
Owner

Hopefully fixed in dev master, if you want to check.
Will release this asap.

sebastianfeldmann pushed a commit that referenced this issue Jul 29, 2018
- Remove PHP_Timer dependency - issue #155
- Add phpunit 7 compability - issue #155
- Fix capacity cleanup simulation
@sebastianfeldmann
Copy link
Owner

Should be working in 5.1.2 ;)

@BonBonSlick
Copy link
Author

Thank you)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

2 participants