Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bump symfony/event-dispatcher version to ~3.0|~4.2 #193

Merged
merged 1 commit into from Jul 29, 2019

Conversation

@mattsches
Copy link
Contributor

@mattsches mattsches commented Jul 29, 2019

I had trouble installing sebastianfeldmann/phpbu-laravel in a Laravel 5.8 project. phpbu-laravel requires phpbu. To me, it looks like the problem is:

$ composer why symfony/http-kernel
laravel/framework  v5.8.29  requires  symfony/http-kernel (^4.2)  
$ composer why symfony/event-dispatcher
symfony/http-kernel  v4.3.3  requires  symfony/event-dispatcher (^4.3)

So Laravel requires the most recent version of the Symfony http-kernel, and this in turn requires version 4.3 or higher of symfony/event-dispatcher.

This is why I would like to update the required version of symfony/event-dispatcher to ~3.0|~4.2 (hoping that this will solve my installation issue ^^).

@sebastianfeldmann sebastianfeldmann merged commit fac8225 into sebastianfeldmann:master Jul 29, 2019
1 of 2 checks passed
Loading
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants