ordereddict issue #273

Merged
merged 2 commits into from Oct 2, 2015

Projects

None yet

2 participants

@KyleAlanDavis
Contributor

I pulled and tried to build since the pip install isn't working on python 2.6 and ended up with this error:

[root@ip-172-31-49-215 config]# dynamic-dynamodb --config /home/ec2-user/dynamic-dynamodb.conf
Traceback (most recent call last):
File "/usr/bin/dynamic-dynamodb", line 4, in
import('pkg_resources').run_script('dynamic-dynamodb==2.1.0', 'dynamic-dynamodb')
File "/usr/lib/python2.6/dist-packages/pkg_resources/init.py", line 735, in run_script
self.require(requires)[0].run_script(script_name, ns)
File "/usr/lib/python2.6/dist-packages/pkg_resources/init.py", line 1652, in run_script
exec(code, namespace, namespace)
File "/usr/lib/python2.6/dist-packages/dynamic_dynamodb-2.1.0-py2.6.egg/EGG-INFO/scripts/dynamic-dynamodb", line 22, in
import dynamic_dynamodb
File "/usr/lib/python2.6/dist-packages/dynamic_dynamodb-2.1.0-py2.6.egg/dynamic_dynamodb/init.py", line 29, in
from dynamic_dynamodb.aws import dynamodb
File "/usr/lib/python2.6/dist-packages/dynamic_dynamodb-2.1.0-py2.6.egg/dynamic_dynamodb/aws/dynamodb.py", line 12, in
from dynamic_dynamodb.log_handler import LOGGER as logger
File "/usr/lib/python2.6/dist-packages/dynamic_dynamodb-2.1.0-py2.6.egg/dynamic_dynamodb/log_handler.py", line 26, in
import config_handler
File "/usr/lib/python2.6/dist-packages/dynamic_dynamodb-2.1.0-py2.6.egg/dynamic_dynamodb/config_handler.py", line 5, in
CONFIGURATION = config.get_configuration()
File "/usr/lib/python2.6/dist-packages/dynamic_dynamodb-2.1.0-py2.6.egg/dynamic_dynamodb/config/init.py", line 163, in get_configuration
'tables': ordereddict()
TypeError: 'module' object is not callable

I'm not a python programmer, but these changes fixed it, enough to allow it to run.

KyleAlanDavis added some commits Oct 1, 2015
@KyleAlanDavis KyleAlanDavis fix ordereddict import
ordereddict() below causes an error, this seems to fix it
4b1e9c8
@KyleAlanDavis KyleAlanDavis fix ordereddict import
ordereddict() below causes an error, this seems to fix it
ff409da
@KyleAlanDavis
Contributor

Apparently I'm a few days behind, and pip install is working, however it also gives this error when installed through pip. for Python 2.6.9

@sebdah sebdah added this to the 2.1.x milestone Oct 2, 2015
@sebdah sebdah self-assigned this Oct 2, 2015
@sebdah
Owner
sebdah commented Oct 2, 2015

Thanks for the contribution @KyleAlanDavis. I could reproduce this and your code does the trick. This will be released together with another bug for Python 2.6 users (#274).

@sebdah
Owner
sebdah commented Oct 2, 2015

I'm working on getting a 2.1.1 release out as soon as possible.

@sebdah sebdah added a commit that referenced this pull request Oct 2, 2015
@sebdah Add release notes for #273 6aafc47
@sebdah sebdah merged commit ff409da into sebdah:master Oct 2, 2015
@sebdah
Owner
sebdah commented Oct 2, 2015

This is now released in version 2.1.1.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment