Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Installation on Kali fails on too short certificate passwords #536

Closed
jfbethlehem opened this issue Aug 24, 2017 · 1 comment
Closed

Installation on Kali fails on too short certificate passwords #536

jfbethlehem opened this issue Aug 24, 2017 · 1 comment

Comments

@jfbethlehem
Copy link

@jfbethlehem jfbethlehem commented Aug 24, 2017

During install from .deb on Kali, the generation of certificates fails. This is due to too short passwords:

Setting up seccubus (2.38.1-0) ...
+ [ configure = configure ]
+ getent passwd seccubus
+ mkdir -p /etc/seccubus
+ mkdir -p /var/log/seccubus
+ mkdir -p /var/lib/seccubus
+ mkdir -p /opt/seccubus
+ chown -R seccubus:seccubus /etc/seccubus /var/log/seccubus /var/lib/seccubus /opt/seccubus
+ cat
+ chmod 755 /etc/init.d/seccubus
+ update-rc.d seccubus defaults
insserv: warning: current start runlevel(s) (empty) of script `seccubus' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `seccubus' overrides LSB defaults (0 1 6).
+ [ ! -e /etc/seccubus/config.xml ]
+ [ ! -e /etc/seccubus/seccubus.key ]
+ [ ! -e /etc/seccubus/seccubus.crt ]
+ openssl genrsa -des3 -passout pass:x -out /etc/seccubus/seccubus.pass.key 4096
Generating RSA private key, 4096 bit long modulus
.........................................++
.................................................................................++
e is 65537 (0x010001)
+ openssl rsa -passin pass:x -in /etc/seccubus/seccubus.pass.key -out /etc/seccubus/seccubus.key
unable to load Private Key
139932162536704:error:28069065:UI routines:UI_set_result:result too small:../crypto/ui/ui_lib.c:778:You must type in 4 to 1023 characters
139932162536704:error:06065064:digital envelope routines:EVP_DecryptFinal_ex:bad decrypt:../crypto/evp/evp_enc.c:535:
139932162536704:error:0906A065:PEM routines:PEM_do_header:bad decrypt:../crypto/pem/pem_lib.c:445:
dpkg: error processing package seccubus (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 seccubus
E: Sub-process /usr/bin/dpkg returned an error code (1)
Setting up seccubus (2.38.1-0) ...
+ [ configure = configure ]
+ getent passwd seccubus
+ mkdir -p /etc/seccubus
+ mkdir -p /var/log/seccubus
+ mkdir -p /var/lib/seccubus
+ mkdir -p /opt/seccubus
+ chown -R seccubus:seccubus /etc/seccubus /var/log/seccubus /var/lib/seccubus /opt/seccubus
+ cat
+ chmod 755 /etc/init.d/seccubus
+ update-rc.d seccubus defaults
insserv: warning: current start runlevel(s) (empty) of script `seccubus' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `seccubus' overrides LSB defaults (0 1 6).
+ [ ! -e /etc/seccubus/config.xml ]
+ [ ! -e /etc/seccubus/seccubus.key ]
+ [ ! -e /etc/seccubus/seccubus.crt ]
+ openssl genrsa -des3 -passout pass:x -out /etc/seccubus/seccubus.pass.key 4096
Generating RSA private key, 4096 bit long modulus
..................................................................................................................................................................++
.....................................................++
e is 65537 (0x010001)
+ openssl rsa -passin pass:x -in /etc/seccubus/seccubus.pass.key -out /etc/seccubus/seccubus.key
unable to load Private Key
140223900906752:error:28069065:UI routines:UI_set_result:result too small:../crypto/ui/ui_lib.c:778:You must type in 4 to 1023 characters
140223900906752:error:06065064:digital envelope routines:EVP_DecryptFinal_ex:bad decrypt:../crypto/evp/evp_enc.c:540:
140223900906752:error:0906A065:PEM routines:PEM_do_header:bad decrypt:../crypto/pem/pem_lib.c:445:
dpkg: error processing package seccubus (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 seccubus
@jfbethlehem
Copy link
Author

@jfbethlehem jfbethlehem commented Aug 24, 2017

Fix to install correctly:

# dpkg -i seccubus*.deb
# apt-get install -f
# openssl genrsa -des3 -passout pass:x12345 -out /etc/seccubus/seccubus.pass.key 4096
# openssl rsa -passin pass:x12345 -in /etc/seccubus/seccubus.pass.key -out /etc/seccubus/seccubus.key
# dpkg --configure -a

After this, you will get:

Setting up seccubus (2.38.1-0) ...
+ [ configure = configure ]
+ getent passwd seccubus
+ mkdir -p /etc/seccubus
+ mkdir -p /var/log/seccubus
+ mkdir -p /var/lib/seccubus
+ mkdir -p /opt/seccubus
+ chown -R seccubus:seccubus /etc/seccubus /var/log/seccubus /var/lib/seccubus /opt/seccubus
+ cat
+ chmod 755 /etc/init.d/seccubus
+ update-rc.d seccubus defaults
insserv: warning: current start runlevel(s) (empty) of script `seccubus' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `seccubus' overrides LSB defaults (0 1 6).
+ [ ! -e /etc/seccubus/config.xml ]
+ [ ! -e /etc/seccubus/seccubus.key ]
+ service mysql start
+ service seccubus start

Loading

MrSeccubus added a commit that referenced this issue Aug 29, 2017
…hrase was too short (also effected docker container)
MrSeccubus added a commit that referenced this issue Aug 30, 2017
…hrase was too short (also effected docker container)
MrSeccubus referenced this issue Aug 30, 2017
…rase-too-short

Issues/536 openssl passphrase too short
MrSeccubus added a commit that referenced this issue Sep 1, 2017
…hrase was too short (also effected docker container)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant