Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Issues with Burp upload #33

Closed
etdsoft opened this issue Sep 9, 2013 · 5 comments

Comments

@etdsoft
Copy link
Contributor

commented Sep 9, 2013

The Burp upload is misbehaving.

Originally reported by @asrozar via the mailing list:

https://groups.google.com/forum/#!topic/dradis-pro/AqT_vm3cs7k

@etdsoft

This comment has been minimized.

Copy link
Contributor Author

commented Oct 3, 2013

I've found part of the problem @asrozar . Could you share a sample file that causes issues?

@asrozar

This comment has been minimized.

Copy link

commented Oct 3, 2013

https://gist.github.com/asrozar/faa3784a22c9fe681fb0

Here you go.

On Thu, Oct 3, 2013 at 11:16 AM, Daniel Martin notifications@github.comwrote:

I've found part of the problem. Could you share a sample file that causes
issues?


Reply to this email directly or view it on GitHubhttps://github.com//issues/33#issuecomment-25629317
.

@etdsoft

This comment has been minimized.

Copy link
Contributor Author

commented Oct 3, 2013

hehe, this is an OpenVAS sample (in the Burp issue...) ;)

@asrozar

This comment has been minimized.

Copy link

commented Oct 3, 2013

Sorry, that was for openvas.

https://gist.github.com/asrozar/67e3f101013ff10f985b

This is the burp file. But I just imported it, and it seems to work.

On Thu, Oct 3, 2013 at 11:32 AM, Avery Rozar arozar@insecure-it.com wrote:

https://gist.github.com/asrozar/faa3784a22c9fe681fb0

Here you go.

On Thu, Oct 3, 2013 at 11:16 AM, Daniel Martin notifications@github.comwrote:

I've found part of the problem. Could you share a sample file that causes
issues?


Reply to this email directly or view it on GitHubhttps://github.com//issues/33#issuecomment-25629317
.

@etdsoft

This comment has been minimized.

Copy link
Contributor Author

commented Oct 3, 2013

Ok, I've fixed a bug, that affects some export files. To provide more detail,

<issues burpVersion="1.5.14" exportTime="Wed Sep 04 18:26:55 EDT 2013">
  <issue>
    <serialNumber>1885570909671078912</serialNumber>
    <type>8389632</type>
    <name>Content type incorrectly stated</name>
    <host ip="10.0.0.1">https://intranet.com</host>

In some instances the :ip attribute of the host tag is not provided in the XML and the plugin was assuming it was always going to be there.

If you can find one burp export that causes a problem right now I'd like to know about it to see if there are any other issues. Otherwise I'll close this item in a few hours.

@etdsoft etdsoft closed this Oct 30, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.