Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Pasting multiline input with escapes doesn't work. #164

Closed
gothrek22 opened this Issue Feb 15, 2019 · 3 comments

Comments

Projects
None yet
2 participants
@gothrek22
Copy link

gothrek22 commented Feb 15, 2019

Hi,

On windows + wsl pasting line end escaped content doesn't actually line escape, treating the paste as simple multiline.

F.e. pasting this:
yum install -y yum-utils \ device-mapper-persistent-data \ lvm2

splits it into 3 commands, instead of one multiline input.

@sedwards2009

This comment has been minimized.

Copy link
Owner

sedwards2009 commented Feb 19, 2019

What are you pasting from? What does the original look like?

@gothrek22

This comment has been minimized.

Copy link
Author

gothrek22 commented Feb 22, 2019

Sometimes from the browser, sometimes from vscode. I see that github didn't keep the formatting. The command originally looked like this:

yum install -y yum-utils \
 device-mapper-persistent-data \
 lvm2

With backslash escaping newline to be treated as one command. The same input works f.e. in guake.

@sedwards2009

This comment has been minimized.

Copy link
Owner

sedwards2009 commented Mar 9, 2019

Fixed in 0.41.1.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.