Skip to content
Laravel Package created at Alerts with pNotify
PHP HTML CSS
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
src
README.md
composer.json

README.md

Alerts

Alerts is a package for show alerts with pNotify jQuery plugin Bootstrap.

Alerts requires PHP >= 5.3, laravel 5.3.|5.4.|5.5.|5.6.|5.8.*

Installation

You can install the package for your Laravel 5 project through Composer.

$ composer require seguce92/alerts

Register the service provider in app/config/app.php.

'Seguce92\Alerts\AlertsServiceProvider',

Add the alias to the list of aliases in app/config/app.php.

'Alerts' => 'Seguce92\Alerts\Facades\Alert',

Then run a few commands in the terminal:

$ php artisan vendor:publish

Configuration

Set icon to true to use the default icon for the selected style/type, false for no icon, or a string for your own icon class.

'icon'	=>	true,

What styling classes to use. (Can be either "brighttheme", "jqueryui", "bootstrap2", "bootstrap3", "fontawesome", or a custom style object. See the source in the end of pnotify.js for the properties in a style object.)

'styling'	=>	'bootstrap3',

Delay in milliseconds before the notice is removed.

'delay'	=>	'8000',

Whether to escape the content of the text. (Not allow HTML.)

'text_escape'	=>	false,

Display a drop shadow.

'shadow'	=>	false,

Opacity of the notice.

'opacity'	=>	1,

notification type [desktop, normal]

'desktop'	=>	false

Basic Usage

Controllers.php or routes/web.php

Alert::info('description')->flash();

Alert::success('description')->flash();

Alert::warning('description')->flash();

Alert::error('description')->flash();

View.php

add function before of section script

  • bootstrap.min.css or font-awesome.min.css
  • jquery.min.js
<script type="text/javascript" src="js/jquery.min.js"></script>
<script type="text/javascript" src="js/bootstrap.min.js"></script>

{!! Alerts::all() !!}
You can’t perform that action at this time.