Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

HIERARCHY_REQUEST_ERR in IE9 #241

Closed
nilshoerrmann opened this Issue Jul 19, 2012 · 3 comments

Comments

Projects
None yet
2 participants

I'm using this plugin for tagging like so:

var participants = $('input.participants');
participants.select2({
    tags: participants.attr('data-members').split(', ')
});

While this works just fine using Webkit or Gecko, I get the following error using Internet Explorer 9:

SCRIPT5022: DOM Exception: HIERARCHY_REQUEST_ERR (3)
jquery.js, Zeile 6497 Zeichen 6

The plugin itself is functional (I can add new tags), but the existing tags are ignored (they are missing in the main input and the search). Any idea what's going wrong here?

I'm using the latest code from the master branch.

The search seems to be working fine. The error always occurs when adding an item (from search or on initialisation).

Contributor

ivaynberg commented Jul 19, 2012

can you post the stacktrace or create a jsfiddle that reproduces?

If you checkout the tagging example on your Select2 3.0 page in Internet Explorer 9 you'll get the error when selecting a tag from the search. IE8 doesn't work either but doesn't throw an error.

can you post the stacktrace

What's the best way to do this in IE?

@ivaynberg ivaynberg closed this in a718dc4 Jul 19, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment