Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

fix(deps): Require find-versions ^4.0.0 #1722

Merged
merged 1 commit into from Dec 29, 2020

Conversation

@72636c
Copy link
Contributor

@72636c 72636c commented Dec 29, 2020

This new version includes a fix for a ReDoS vulnerability in semver-regex that is flagged by some source composition analysis tools like Snyk:

https://snyk.io/vuln/SNYK-JS-SEMVERREGEX-1047770

It's a major version because it drops support for Node.js 6.x. This doesn't affect us since we already require Node.js >=10.18.

https://github.com/sindresorhus/find-versions/releases/tag/v4.0.0

This new version includes a fix for a ReDoS vulnerability in
`semver-regex` that is flagged by some source composition analysis tools
like Snyk:

https://snyk.io/vuln/SNYK-JS-SEMVERREGEX-1047770

It's a major version because it drops support for Node.js 6.x. This
doesn't affect us since we already require Node.js >=10.18.
gr2m
gr2m approved these changes Dec 29, 2020
Copy link
Member

@gr2m gr2m left a comment

Thanks!

Loading

@gr2m gr2m merged commit 52238cb into semantic-release:master Dec 29, 2020
3 checks passed
Loading
@semantic-release-bot
Copy link
Collaborator

@semantic-release-bot semantic-release-bot commented Dec 29, 2020

🎉 This PR is included in version 17.3.1 🎉

The release is available on:

Your semantic-release bot 📦🚀

Loading

Xunnamius added a commit to Xunnamius/semantic-release that referenced this issue Feb 11, 2021
This new version includes a fix for a ReDoS vulnerability in
`semver-regex` that is flagged by some source composition analysis tools
like Snyk:

https://snyk.io/vuln/SNYK-JS-SEMVERREGEX-1047770

It's a major version because it drops support for Node.js 6.x. This
doesn't affect us since we already require Node.js >=10.18.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants