Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Social Meta module - Pasting an image URL in Custom Image field is broken #1074

Closed
wpsmort opened this issue Aug 10, 2017 · 7 comments

Comments

Projects
None yet
4 participants
@wpsmort
Copy link
Member

commented Aug 10, 2017

Reported by Matt @syntax53 here - https://wordpress.org/support/topic/using-incorrect-facebook-ogimage/#post-9398765

In version 2.3.15 the ability to paste an image URL in the Custom Image field stopped working. You can still paste an image URL in the Custom Twitter Image field.

@wpsmort wpsmort added the Bug label Aug 10, 2017

@wpsmort wpsmort added this to the 2.3.16 milestone Aug 10, 2017

@wpsmort

This comment has been minimized.

Copy link
Member Author

commented Aug 10, 2017

@arnaudbroes Can you determine which commit in v2.3.15 broke this.

Steps to reproduce the issue:

  1. Create a post and paste an image URL in the Custom Image field. You can use any image URL from any website
  2. Save the post and then view the source code and see if the image URL is shown in the og:image meta tag
@arnaudbroes

This comment has been minimized.

Copy link
Contributor

commented Aug 10, 2017

@michaeltorbert
Traced back to 2.3.14.
One of these commits (same as #1053) caused the issue:

56db40c
04184bb
eaf66d8
c50b65d (guessing this one)
762f9e3

@michaeltorbert

This comment has been minimized.

Copy link
Member

commented Aug 10, 2017

This works for me. Did you select it in the radio button?

screen shot 2017-08-10 at 5 43 05 pm

screen shot 2017-08-10 at 5 42 22 pm

@michaeltorbert michaeltorbert removed their assignment Aug 10, 2017

amostajo added a commit to amostajo/all-in-one-seo-pack that referenced this issue Aug 11, 2017

semperfiwebdesign#1074 Turns on image checker on custom url change
Turns ON image checker on custom image value change (most likely due to
custom url being pasted). Compatible with image uploader.
@amostajo

This comment has been minimized.

Copy link
Contributor

commented Aug 11, 2017

PR #1078 Ready for testing

@wpsmort

This comment has been minimized.

Copy link
Member Author

commented Aug 11, 2017

@amostajo This works fine until you try to paste in a new image URL. When you paste in a new URL it doesn't change the image in the og:image meta tag.

Steps to reproduce:

  1. Edit a post and paste in the URL for an image in the Custom Image field then click Update. The image should be correctly reflected in the og:image tag in the source code
  2. Edit the post again and paste a new URL in the Custom Image field, replacing what was there from step 1 and click Update. The image in the source code should still be what was set in step 1
@amostajo

This comment has been minimized.

Copy link
Contributor

commented Aug 12, 2017

@wpsmort It did work for me. Make sure you force refresh of assets by pressing F5 on your browser.

@wpsmort

This comment has been minimized.

Copy link
Member Author

commented Aug 14, 2017

@amostajo It's working for me now too. I cannot reproduce the issue I was seeing on Friday at all.
PR #1078 is ready for code review

@wpsmort wpsmort assigned michaeltorbert and unassigned amostajo Aug 14, 2017

michaeltorbert added a commit that referenced this issue Aug 15, 2017

#1074 Turns on image checker on custom url change (#1078)
Turns ON image checker on custom image value change (most likely due to
custom url being pasted). Compatible with image uploader.

@michaeltorbert michaeltorbert removed their assignment Aug 15, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.